SDK Beta - cu2p2beta Branch Feedback



  • So far, cooking and uploading mods seems to work perfectly.

    Server mod downloading works OK too. The first time I tried the ServerWorkshopTool it failed, but second time it worked. Can I request that that executable is actually in the server files by default, too? Seems silly that it isn’t.

    Connecting to a modded server however is really quite bad. My game client seemed to download the whole mod package in as little as 2mb chunks and paused for some time between each chunk. Eventually it got there, but I have no doubt that others will give up when they see it start-stop continuously.

    Oh and my server didn’t appear in the server browser, but that may have just been dodgy server browser.Actually on the server (this is a locally hosted dedicated server, btw) I had this really annoying and constant stuttering.

    Every few seconds the game freezes briefly and the server window prints a message like so:
    "DevDlc: SDK Code Mod: aocffa-moor_p"
    The server regularly spams this and every time the client lags.This definitely needs fixing before release because the game is completely unplayable with the stuttering.