Really low fps with good system specs, tried all fixes in the sticky.



  • I have an AMD FX 6100 with a Gtx 670 2gb 8gb of ram.
    Tried every fix to no avail someone please help.



  • Make sure you have your ragdoll length turned way down. Since the ragdolls have full physics and are interactable, having a lot of them on screen makes your CPU want to off itself.



  • I had a similar problem with an FX8100 after a lot of investigation it turned out to be the bios setting of cool and quiet - this wasn’t working properly and was turning down the processor power in game resulting in the low fps. turning off cool-n-quite in the bios fixed it nicely.