'Authentication failed' when trying to join a server



  • The same clan guy I mentioned above just sent me a message and said this kind of stuff is all over the Steam forum. I think it’s Steam now to be honest.



  • @all

    Seems to be a global issue affecting both official and clan servers, have made the devs aware.



  • It’s quite common as I see. “Authentication failed” or “Your connection to the Host has been lost” appearing no matter what server I join and as Quigleyer said, yesterday everything was fine.

    Probably something glithcy about the latest 50 mb quickpatch after CU2 Patch 2.



  • @MonkeyFiend:

    @all

    Seems to be a global issue affecting both official and clan servers, have made the devs aware.

    I think it might very well be Steam’s fault at this point. The Steam forums talk of many issues with the network and being unable to reach the Steam network at this time, so it’s entirely possible this is on Valve’s hands.



  • Thanks for the replies, glad to know I’m not the only one. Was hoping it wasn’t some new ‘blackscreen’ issue lol



  • I fixed the ‘Authentication Failed’ and ‘Connection to Host Timed Out’ by going to Steam Library > Chivalry Medieval Warfare > Rightclick > Properties > Local Files Tab > Verify Integrity of Game Cache.

    After verifying it said 4 files were the wrong ones, downloaded them, and now I can join all servers again.

    However, all of them still show as full, even while there’s no-one on. So it’s still impossible to find a game that actually has people in it.



  • There’s been another 54.2mb patch. Is the issue fixed for everyone in this?



  • @MonkeyFiend:

    There’s been another 54.2mb patch. Is the issue fixed for everyone in this?

    This problem is steam related. A lot of games like Rust or DayZ for example aren’t working either.



  • @MonkeyFiend:

    There’s been another 54.2mb patch. Is the issue fixed for everyone in this?

    Yes, myself as well as 2 clan mates are now playing properly. thank you!



  • @MonkeyFiend:

    There’s been another 54.2mb patch. Is the issue fixed for everyone in this?

    I had the issue fixed by validating Steam content, which updated 4 files, earlier this evening. It worked, I played, had to quit Chiv and then the 54.2 Mb patch hit me and now I got the problem again.

    So no, for me the latest patch broke the game again. ‘Connection to Host Timed Out’ on all servers.



  • @quigleyer:

    Yes, myself as well as 2 clan mates are now playing properly. thank you!

    And it turns out it’s only unofficial servers I can play on still. SHould have checked that, sorry.



  • Yesterday everything was fine until I stopped playing, and a 54 MB patch was downloaded. So today I couldn’t play, until I verified the cache and those 4 files were renewed. Then I could play, until I again stopped playing and another (or the same) 54 MB patch was loaded. Then I got the Host timeout error again.

    So I verified the cache again , and indeed 4 files again failed verification. Now fixing those didn’t even help.

    I definetely see a pattern between these mini-patches and not being able to play. So for me, it seems the cause of the problem, not the solution.

    Going to try see if deleting all local content and re-downloading the whole game will help, but there goes my evening.

    Redownloaded the game entirely, and now the game works again.

    Disabled auto-update before that 54 Mb patch can strike again.



  • @MonkeyFiend:

    @all

    Seems to be a global issue affecting both official and clan servers, have made the devs aware.

    It’s kind of pathetic that a forum moderator has to let the devs know that their game is broken. Do they not even play their own game?



  • Whatever happen while I was at work seems to have fixed the issue. I didn’t download another patch either. Assuming steam got their crap together and allowed people to play the games they purchased. Thanks for the feedback from you all, greatly appreciated



  • @Flippy:

    It’s kind of pathetic that a forum moderator has to let the devs know that their game is broken. Do they not even play their own game?

    Since the patch the game was working, recent issues were linked to steam which is beyond the control of the devs, hence other games like DayZ started having problems too. I messaged them when I became aware of the issues in case they hadn’t already realised as I’m sure they don’t just sit around playing their own games all day or sitting on the forums in a cat like state of alertness waiting for issues to arise.

    My post was to try and communicate that the devs were aware of the issue, before the influx of complaints about the game being broken flooded in.

    It’s kind of pathetic that you didn’t grasp that ;)


Log in to reply