After patch I once again am unable to get servers to show up.



  • Even with the Alternate Server Browser, I am getting 4-5 servers with only a few people on each, whereas last week and before the patch I was getting loads of full servers, loads of nearly full servers etc.

    Less than a week ago everything was fine.

    Help me please. No network settings have been changed anywhere.



  • Server browser got broken again with the patch(es). Always happens without fail.



  • It’s steam that got some probs atm, not chivalrys browser.



  • @Xylvion:

    It’s steam that got some probs atm, not chivalrys browser.

    You must be new here…



  • @SOC:

    You must be new here…

    haha but I actually do believe Steam is currently having a problem. There are a few non-Chivalry steam topics that are dealing with connections issues in games. Right now you can only join unofficial servers that don’t fail authentication (because I guess they aren’t checking for authentication).

    If your servers aren’t showing up make sure to check your browser filter. Try making all visible. I always have full/empty games not showing and as soon as I showed them I just realized that no one is playing online right now, not that the servers aren’t showing up.

    If you do manage to get into a server (I did, 2-3 of them) you’ll notice the average is about 200-300 ping right now. I think everyone from EVERYWHERE is crowding into these few servers. It’s almost not worth playing atm.



  • @SOC:

    You must be new here…

    It’s steam. Same error in plenty of games.



  • Right now I’m seeing every server that has had any population in the past 24 hours it seems. It says every single official server is full, but obviously only a few of them have any population in them.

    All the other games that use Steam server browsers are working just fine.



  • @SOC:

    Right now I’m seeing every server that has had any population in the past 24 hours it seems. It says every single official server is full, but obviously only a few of them have any population in them.

    All the other games that use Steam server browsers are working just fine.

    This just happened to me too, where before they were all showing empty. I got into int duels with 16/16 playing and saw 4 guys in there.

    I guess this is preferable to the “server is half full but won’t let you join because it thinks the game is full” bug.



  • @SOC:

    Right now I’m seeing every server that has had any population in the past 24 hours it seems. It says every single official server is full, but obviously only a few of them have any population in them.

    All the other games that use Steam server browsers are working just fine.

    This. Trying out like 6 servers in a row, eventually just have to settle for a server that has 6 players or not play at all. I think it’s just about time to uninstall this game.



  • Stick this rubbish in the bug report or feedback or support sections We seem to have lost order on the boards lately. A few months backwe were told to stick posts such as op’s in the right places. blah blah the weather changed drastically yesterday and Steam had issues with connections not chivalry. Its just unlucky that TB released a patch at that time.


Log in to reply