Weapon Unlocks Resetting: Fixed.



  • Hello all!

    Since you are reading this I am assuming you (like myself) are having problems with weapons not staying unlocked and/or kills resetting to their original value after each game you play. (Frustrating, I know)

    After looking at countless material on how to ‘fix’ the problem. None of it worked for me. It was only temporary.
    But I’ve learnt from it all and I’ve came up with my own solution to the problem.
    You can unlock all the weapons for every class permanently. And it isn’t even that hard to accomplish.

    Now, you’ve all read the ‘fix’ by editing the UDKStats.ini Files. Changing False to false. (Change the uppercase F to lowercase). Make sure you do this.

    Find the UDKStats file inside
    My Documents/My Games/ Chivalry Medieval Warfare/UDKGame/Config/ (UDKStats.ini)

    You need to edit the values to 100. The top value is your level xp but it doesn’t take effect online.
    Look at the screenshot to see what values.
    Screenshot.
    UDKStats Documents.png

    When you have edited the file with Notepad, save and exit.

    Something else I read was to click on the steam tab (top left of your steam client) and click settings.
    On the next screen click the ‘cloud’ tab and un-check the box 'Enable Steam Cloud synchronization). So that it is now disabled.
    I’m not sure if this has anything to do with it but it was something I did. It might be related.

    Here is a screenshot of all the Archer unlocks. (It even works for the veteran helmets too). I’m only level 5.
    Veteran Helmet’s Unlocked.png
    Archer Unlocks.png

    I’m glad to share this information with you guys. I know how annoying these bugs are considering the game is actually a lot of fun…
    I’ll try and fix the level up bug but I believe they might be server side and not client side.

    And please don’t hold me to blame for any problems that occur if something goes wrong.
    Best advice is to uninstall the game. Delete Chivalry in your My Games folder and re-install the game.

    Now, go pillage some cities and kill the king while you’re at it!



  • Btw I’ve done it again and you don’t need to go through this much effort. It’s as simple as just editing the UDKStats file in my games with normal notepad. You don’t even need to set it as read only. Just set the values to 100. Don’t delete the lines under false and you’re set



  • Hey Torn Banner, your programmers suck. This guy just did what you should’ve done over a year ago. Bravo.



  • Thank you SO MUCH for this fix! There are only a few issues. For example, I did not unlock any of the special weapons (i.e. fire arrows, buckler shield, oil pot, etc.) and I was wondering if you new how to fix this. I would also love it if you knew how to fix the problem of servers not showing up.



  • When i did your fix this is what happened: I unlocked nearly everything for vanguard, weapon unlocks went down slightly for archer and knight, and now some of the man at arms stuff is set for 999 kills to unlock. I think its because i could only find Local Disk [C:] /Programs Files (x86)/Steam/steamapps/common/chivalrymedievalwarfare/UDKGame/Config/ (UDKStats) and not the other file, but please tell me if theres anything else i might have done wrong and also if i buy the deadliest warrior expansion do you think the same thing would happen for that?

    Sorry about the highlighted crap.



  • Thx for this temporary fix , i would prefer to unlock my weapons , but till the developers will repair the level bug , i will use the fix.



  • Thx for the fix. I just hope steam won’t consider this as cheating :)



  • There are a lot of fixes to servers not showing up. Do a Google search and try a few. You can fix the problem is 10mins or less.

    IMHO Don’t buy the expansion. No where near as many people play it. It has the same bugs I believe. And doesn’t run as well for me at least. I accidentally bought both of them on the sale and I wish I didn’t…

    Also, thank you all for replying. Glad to see some of my efforts went to good use ^+^



  • May I just add that using either the customization screen or the UDKcustomization.ini to equip a helmet you don’t legitimately own(like a rank 50 helmet while you’re only rank 5) will reset your helmet to the default as soon as you go online?

    You can set your rank to 100, equip a golden helmet and go fight bots but as soon as you visit an actual server it’ll all reset to your default. Can someone confirm whether or not this is still the case for when you disabled Steam Cloud Synchronizing?

    Also going seriously off-topic here: does anyone know the Id of the kickstarter helmet? It would be cool to equip it on a vanguard and slay bots with this thing on. XD
    (If I know the id of that thing I’ll be able to equip it via .ini editing.)



  • Thank you Master



  • Guys , it worked for me but now that the bug is fixed , how can I reset everything to its default value(and start unlocking them myself) ? I don’t have the initial file and I don’t remember what its contents were . Can I just delete UDKstats.ini and start the game over ?
    Thanks in advance


Log in to reply