Please wait while the game is loading + server list problems - NOW WITH VIDEO!



  • SOLVED

    The issue is solved by having your router in Bridged Mode.

    Bought this game, and vastly disappointed in the fact it’s almost unplayable due to the poor server list and apparently connectivity in general.
    **
    I paid for a functioning product, and I expect a refund unless this can be fixed.
    **

    The Video:

    http://www.youtube.com/watch?v=haTFzBb97iA

    In this thread I will give you a full summary of the symptoms, and things I have tried in order the solve the issue so you can easily see what has been tried.

    The Symptoms

    Note: I use no server filters whatsoever
    Note: All my other Steam games are working fine and finding their respective servers

    1. Whenever I launch the game Chivalry: Medieval Warfare and press Join Game, I get a full server list with I believe every server available listed.
    2. However if I switch to my History tab, I get nothing. If I switch to my Favorites tab, I get nothing ( even when I have added servers to favorites. )
    3. If I switch back to the Servers tab AFTER visiting History/Favorites, I get nothing most of the time. SOMETIMES I get around 4-5 servers listed, but no more ( why 4-5 instead of all or nothing ? )
    5. If I visit my Friends tab and switch back to Servers, I always get 4-5 servers. This ONLY happens with the Friends tab, not with Favorites or History.
    6. I can’t connect to most games. I’d say 9/10 times I’m stuck in “Please wait while the game is loading.”

    What I can do:

    -I can connect to some servers by using the console command “open ip:port” -even if I can’t see them in the server list anymore.
    -I can connect to any server a friend of mine has connected to. In essence, I can follow my friends to servers without problems.
    -If I relaunch the game, I get all servers listed again
    -If I manage to connect to a game, leave it, and check Servers again I get all of them ( unless ofcourse, I visit another tab… )

    Things I have tried to solve the issue that changed something:

    • Put my computer into DMZ mode ( ALL service ports open ) and disabled Windows Firewall and Windows Defender all simultaneously, leaving my PC completely open. This action did change something; The servers I got listed all had 300-800 ping. Normally they range from 30-300 ping depending on their location. The amount of servers listed still varied per game launch, but showed most I think.

    Things I have tried to solve the issue that changed nothing:

    • Put my computer into DMZ mode ( ALL service ports open )
    • Opened ports required by the game and Steam in my Windows Firewall
    • Reinstalled the game multiple times
    • Restarted Steam
    • Reinstalled Steam
    • Verified game cache multiple times
    • Allowed both steam and C:MW through Windows Firewall
    • Disabled Windows Firewall completely
    • Disabled Windows Defender completely
    • Deleted Chivalry folders in "*:\Users***\Documents\My Games\
    • Deleted *.blob -Files in *:*\Steam
    • Renamed the config folder to Config.old allowing the game to create a new one
    • Used the console command “Disconnect” as suggested by TB
    • Checked that I have DHCP enabled
    • Allowed both Steam and C:MW and all it’s executables ( Launcher, UDK, CDW both x64 and x32 ) through Windows Firewall

    My modem make, model and picture:

    Cisco EPC3825 ( picture: http://www.zero13wireless.net/wirele…00/epc3825.jpg )

    Update 8.1.2014: I contacted Torn Banner about a refund, no reply for 10 days. Emailing them again today.
    Update#2 8.1.2014: Received a response from Torn Banner, can be found at post #11.
    Update 11.1.2014: Received an email from Torn Banner saying they are now fully investigating this issue, as it appears only me and a few others have it and they are puzzled by it.
    Update#2 11.1.2014: Added video of my issue.



  • Yup. Same thing happening to me.
    I deleted that config file and done all that shit, it loaded up a few servers…. then bam, all of them disappeared.
    That was a few weeks ago.
    Still not getting any servers no matter what I do.
    It did show some servers for a whole day once though, never touched the configuration and then it died on me for no reason.
    Please fix your server browsers Torn Banner, mucho appreciato! :)

    PS: Server issues have been around for a LOOOOOOOOOOOOOOOOOOOOONG time. They’re probably never going to fix it. Try joining off a steam friend, that works for me.



  • Hi,

    i had the same problem. After activating DHCP (obtain IP configuration automatically) it worked. Maybe check your Network configuration aswell.

    http://forums.tornbanner.com/showthread.php/17797-Can-t-join-Server-quot-Please-wait-while-the-game-loads-quot



  • DHCP is activated for me. Still the same issues. Torn Banner, is this your idea of customer care?



  • Hi,

    try this:

    • Restart your Router + Modem (Wait 5 minutes between Off/On)
    • On your Computer open cmd.exe (Run -> cmd)
    • Type ipconfig /release
    • Type ipconfig /renew
    • You can also try Deactivating/Activating your Ethernet Adapter

    Run cmd.exe as Administrator.

    Try this aswell:

    • Verify Integrity of game cache (multiple times)
    • Deleting Chivalry folders in "*:\Users***\Documents\My Games\
    • Deleting *.blob -Files in *:*\Steam
    • Deactiving Windows Firewall
    • Turn off Antivirus Programm

    Thanks.



  • I’m also having problems to connect to the servers. Enabling compatibility mode (windows 7) allowed me to connect to customization. But still, I want to play the game :(



  • Thanks for your advice Xndrexs. I have now done everything you described but the problem still persists. At times when launching the game and going to the server list for the first time, I get a lot of servers.

    But if I switch to say, friends or the favorites tab ( favorites never show up btw ) and go back to the main list, then I get nothing. The fact that the list works when first loading it but not after switching tabs tells me that this is an issue with the game, not my settings or hardware.

    If it was hardware or other settings, it would either work or not work at all.

    So yeah, awaiting what you’re gonna do about it Torn Banner, as the developers of a fully launched videogame that people pay real money for.

    I already emailed Torn Banner for a refund, but they haven’t replied. Calling the gaming related press and blogs to spread the word about a half functional game and nonexistent customer care next course of action?



  • 8 days without customer care or support from Torn Banner Studios.



  • 9 days without customer care or support from Torn Banner Studios.



  • 10 days without customer care or support from Torn Banner Studios.



  • After emailing Torn Banner the second time I got a response, during the same day ( perhaps my first mail was lost somehow since I got no reply for that at all. )

    Tom Banner wrote:

    Hello,
    I personally tried to reproduce this, however the only time I was unable to
    receive the server list again was accidentally clicking the history tab
    instead of the servers tab. We apologize for this issue.
    Can you please verify your installation through Steam.

    To Verify

    • Right click on the game
    • Click on properties
    • Click on the local files tab
    • Click on verify integrity
    • Run that a second time to ensure everything is copacetic then restart
      your pc
    • Then try running the game again

    –- Torn Banner Studios

    While I already tried what was suggested, I still appreciate atleast getting a response. But the problem still persists. Take note, I have no router, my firewall is disabled when trying to solve this, and all my other Steam games are working and finding servers perfectly fine ( Team Fortress 2, Killing Floor, Rising Storm, CS, TL2 to name a few. )

    What can cause this that hasn’t already been tried?



  • Hi,

    I would do the following (if possible) to narrow down the problem:

    • Install and try Chivalry on another Computer in your current Network
    • Try Chivalry on another Network/Internet connection with your current Computer (Friends house for example)

    Then you know, if it is your Computer or your Internet connection. If nothing works, it is actually the game.

    I know it is a lot of trouble, but I have no more ideas for a Software fix.

    On the other hand, you connect to the Internet directly through a Modem? What is your Internet connection?

    Thanks.



  • Also have you tried connecting via console to a server directly with IP ?



  • Hey again Xndrexs and thanks for your continued support. I also thought of the “elimination process” but sadly my GF’s computer is nowhere near able to run Chivalry and the closest buddies live 100km away since I moved to study. I also tried using the “Disconnect” -command in the console suggesed by TB, but that didn’t help either. Also reinstalled the game for the second time, nothing.

    I connect directly trough a modem yes. The speed is 10mb/1mb. The name of the connection in my control panel is “Ethernet.”

    Really sad if I have to throw a game I just bought ( and enjoy when I manage to connect ) into the trashcan just because it doesn’t work properly. It’s so weird that at times I get 4 servers, and sometimes 0, and sometimes all of them ( when launching the game and loading the list for the “first time”. )



  • Hi Runic,

    I was wondering how you could have DHCP enabled if you are connected to a Modem directly. Are you sure there is no Router between (Ethernet!)? Maybe check that again and give me the type of Modem/Router.

    Please open cmd.exe and type “ipconfig” and copy the results.
    Also type “ipconfig /flushdns”.

    If there is a Router in use (pretty sure there is) then we can put your Computer into DMZ (testing only!).

    You can add me on Steam for better Support: xndrexs



  • Today I received an email from Torn Banner that they are now fully investigating this issue as apparently only me and a few others have it and it is puzzling them. So a raise of my hat for that for TB if thats true.

    I don’t know much about DHCP, but it does say it is enabled for me.

    My modem model and make: Cisco EPC3825 ( picture: http://www.zero13wireless.net/wireless/APs/al_descubierto/ciscoepc3825/800x600/epc3825.jpg )

    I am currently uploading a video of my issue, will post it later.



  • Here is the video of my issues, also added to the first post:

    http://www.youtube.com/watch?v=haTFzBb97iA



  • Solved the issue. The issue is solved by having your router in Bridged Mode ( for me anyways. ) Majority of routers and modems in many countries do not have this enabled by default when a person purchases an internet connection from an ISP, and it does require a bit more than average knowledge to do ( none of my friends sure can’t do it without help. ) This is something to keep in mind for the future ( TB. )

    Everything now works perfectly, the list is instantly refreshed and history works and so on. Do note all my other Steam games worked fine to beginwith, only Chivalry had issues. Guess it has issues with NAT or something (?)


Log in to reply