Game Keeps Freezing



  • Hi all,

    I’m new to Chivalry, and I just bought the game on Steam a few days ago during the Winter Sale. I was able to make it through the tutorial, so then I decided to try out multiplayer. When I connected to the server, I was allowed to chose a team. However, once I chose a team, as soon as I selected my class, the game crashed to desktop, crashing Steam as well. With the recent patch, I have been able to make it for a few seconds into the game and run around for about 5 seconds before the game freezes. I do not even get a popup saying that the game has stopped responding, it simply freezes and then crashes to desktop. I have enabled XP(SP3) compatibility mode, run it as an Admin, and verified the game’s local files integrity. However, I still have the same issue. If someone could help, that would be great. Maybe it’s a sound issue? Check the specs please. I also have the logs available but I can’t make any sense of them.

    • Alex

    System Specs:

    Intel i5-3570k
    Corsair H100i
    MSI z77 g45 gaming mobo
    8 gB 1600 mHz Ballistix RAM (dual channel)
    1TB WD Black HDD
    Asus GTX770 DCUII
    Corsair CX750
    CMStorm Trigger Quickfire Keyboard
    Fractal Design Arc Midi R2
    Asus DSX Sound Card <– Would this be an issue? The tutorial is playable and also I have lowered the sample rate and bit depth to 24bit 44100 Hz



  • Hi,

    can probably get a bit more info from the launch.log locatedinmy documents/ my games / chivalry…
    Also worth a try is to renMe the config folder located in the same place in case something odd has crept into your configs (after renaming the folder reverify the game cache to download clean configs)



  • @MonkeyFiend:

    in case something odd has crept into your configs (after renaming the folder reverify the game cache to download clean configs)

    How does something odd creep into your configs? And what exactly is the odd thing in question? Virus, corrupt data, I’m genuinely curious because I’ve seen you mention this before.



  • I’m not sure either. Perhaps if I delete all local files and redownload, the configs will reset? It’s really quite perplexing


Log in to reply