Empty Server List



  • Hi all,

    Bought Chivalry a few days ago, and been completely unable to play online because I have a permanently empty server list. Here’s what I’ve tried so far;

    • Opting out of any beta options on steam
    • Verifying the installation
    • Checking for any updates
    • Completely removing the installation and re-downloading
    • Deleting/renaming config files
    • Launching with an external server browser (when I get into the game I get a “Connection with server lost” message)
    • Running with full privileges

    When I try and go into the “Customisation” screen, I get a message that says “Difficulty communicating with server, please try again later.” Additionally, if I play a bot game my name is simply “Player” as opposed to my Steam game.

    I’ve trawled google and the steam forums and tried everything, and nothing seems to be helping my situation. I’m all out of ideas. Anyone have any suggestions?



  • I have got the exact same problem. I have tried just about everything that I read, including everything written by the previous poster (Except for deleting the config files since I couldn’t find the exact ones), and I’ve also tried deleting ClientRegistry.blob that a user suggested in another post, to no avail.

    I HAVE gotten the game server list working sometimes, but it seems completely random as to the times it actually wants to work. I got it working once by restarting steam, then it worked for a day or so.
    After that however, a couple hours after playing I tried getting in again and once again noticed a complete lack of servers that no amount of steam restart fixed.

    Any idea on how to fix that?



  • Hi,

    I had problems with an empty server browser too. And when I saw servers then I could not connect “Please wait while the game loads”.

    Please check your Network configuration. DHCP should be activated (obtain IP automatically). Sometimes I still get an empty server brower, but restarting Steam solves it.

    Maybe that helps.



  • Same problem, empty server browser. Worked once, didn’t work, tried all the fixes, worked once, didn’t work… rinse and repeat.

    This is easily the buggiest game I’ve paid money for since the Win95 days. Too bad, since when it works it’s pretty fun, but at this point I’ve spent far more time trying to get it to run than I have playing it.


Log in to reply