Help! Errors when trying to host our mod!



  • Hello to whomever reads this. Snoe and I have been experiencing some issues since we began hosting our mod on our server for testing. After spending time figuring out the mod process for Chivalry and cooking with the new launcher we uploaded to the workshop. You can find the mod here for alpha testing in case you want to check it as well. http://steamcommunity.com/sharedfiles/filedetails/?id=214027129

    We followed the directions here https://tornbannerjira.atlassian.net/wiki/display/CHIVCOM/Uploading+to+Steam+Workshop along with some tips from Kimiko but once we had it running on the server errors were popping up. The error we received when trying to join was the, “Server not communicating with workshop” error. I researched the problem and asked around and saw this post from Crustacean.

    “Anyone who has previously uploaded something to the Workshop, please reupload it. This should fix the issue where servers would show an error about not being able to communicate the Workshop information. If you uploaded with a GUID before, reuse the GUID to just upload overtop your old file; if you uploaded before we added that feature (i.e. on the beta app, before the patch), you’ll have to delete your old file.”

    We did follow this even though the post is very old and wouldn’t you know it, the mod suddenly worked.

    The next part is where we need help. After I restarted the server later we received the same error again. I tried everything I could think of to try and get it working including reuploading the cmwsdk file but had no luck. Today we uploaded the workshop file with another update(nothing actually got changed in the update, it’s just to make the workshop work apparently) and it started working again. Is there any more reliable fix to make sure we no longer get the workshop error we were receiving? Is it a workshop problem or something wrong with the mod? I tested it last night with another server and was getting the same problem until we uploaded the new version today. Why would it stop working after it was functioning?



  • Alright I believe I figured out what was causing it. I wonder why the workshop seems so buggy with server/client files…


Log in to reply