Arena is broken…..



  • Ok, so I have recently noticed that the map “arena,” not sure about “arena3” though, has been giving me weird problems.

    Every time I join a server with the map playing it will put me on the blue loading screen and will load for about a minute or so until the main menu’s music comes back. The loading screen doesn’t disappear, however. It gets stuck on it forever. Like I said, though, the music comes back which may mean that it thinks it is on the main menu. I am forced to alt tab and manually close the game. I have had this problem before as well, but it didn’t seem to be directly associated with arena. I posted a thread on it previously, but the bug seemed to resolve itself after a patch.

    I have tried reinstalling the game, but it hasn’t worked. Verified files before and after the reinstallation, each time it says that 4 files failed to validate. Still doesn’t work before or after.

    My dxdiag is attached.



  • OK guys, I have an update! Not sure why nobody helped me before, so BUMP

    After the last couple of patches, I have still been unable to FFA on arena3, but this time it gives me an actual error message instead of breaking my game.

    This is what it says:
    “package ‘aocffa-arena3_game_5’ version mismatch [package A7EE4D2C47172E846105A69C91F5DF9C, info 7BA2184C4FA9FA958F54FC9B3D808E83]”

    Devs, help me! I haven’t been able to play on arena in what seems like MONTHS. Even after reinstalling.


  • Developer

    Uh…

    Try searching in the Chivalry directory for

    AOCFFA-Arena3_Game_5.udk

    There should be exactly one, in chivalrymedievalwarfare\UDKGame\CookedPC\AOC\Levels\Arena\RepurposedArena

    If there’s more than one, delete the other one. If there isn’t delete the good one and try verifying again?



  • is there any way that the custom map night arena could be causeing this stuff?

    it was an epic map but after the last patch if you try to run it it goes to tdm moor instead of night arena.

    also since the last patch if I don’t join my server right as the map changes I cannot get in, it hangs on the loading screen, this makes it really hard to try and test on our modding test server as its enough to recook and redownload the file from teamspeak install it then start the game only to have to deal with this issue, not being able to join the server.

    it gets very frustrating expecially when we are trying to do several recooks/updates a day



  • I actually remember playing on Night Arena… hmm



  • Crust, I looked in and found this:

    3 files
    AOCFFA-Arena3_Game_5.udk
    AOCFFA-Arena3_p.udk
    AOCKOTH-Arena3_p.udk

    Do I delete all of them or just one or what? Do I need to delete the KOTH one and the other FFA one?
    Sorry may seem like a derp question but I don’t want to screw anything up too badly.


  • Developer

    Take out AOCFFA-Arena3_Game_5.udk

    You can delete all of them anyways, after you validate it’ll grab the new ones and everything should be fine.

    Do you only see one Arena3_Game_5? If Night Arena installed a package with the same name into CookedSDK, the game shouldn’t be using it, but maybe it is…



  • Deleted all arena versions and reverified, deleted lava arena/night arena (forgot what it was called, basically the arena that was all black looking) and all of my other custom maps, reverified, EVERYTHING WORKS!

    :D thanks.