Framerate dropping to 15 from 60 during combat. Very annoying.



  • Hey guys

    I’m getting constant FPS drops only when I fight with people. I can’t even hit straight because the framerate stutters real bad and I end up overshooting my blade and missing. I tried changing the bsmoothframerate to FALSE, minframerate=0, max =120. Nothing changed. Still bad FPS. It’s only happening after the patch.

    I have pretty excellent specs so no it has nothing to do with my laptop either.



  • @Sir:

    I have pretty excellent specs so no it has nothing to do with my laptop either.

    That’s a really funny sentence.

    Please list your specs. It could help us diagnose your problem.



  • Like Flippy said, a laptop with excellent specs is pretty funny.

    I’d try to set the ragdoll length to a bare minimum and character detail to low.



  • @Flippy:

    That’s a really funny sentence.

    Please list your specs. It could help us diagnose your problem.

    Win 7 64bit
    i7-3610QM @ 3.6Ghz
    670M 3gb ddr5
    16 GB DDR3 RAM
    OrdinaryHDD, no SSD
    Not running FRAPS, game’s graphics are not managed by NVIDIA control panel

    I only run the 32 bit version because the 64 bit is a lost cause, just too laggy (framewise)

    The problem happens only during face to face combat. I never had this issue before, only very rarely. But after the recent CU patch, it happens too often.



  • The game’s name was changed from UDK.exe to CMW.exe. This can cause it to use the built in graphics card on your CPU. Google how to change it from using your CPU to your GPU.



  • Right click your desktop, go to Nvidia Control Panel, go to Manage 3D settings. Follow instructions in the pic shown here. So make sure to locate CMW.exe in either 32bit or 64, whichever you play in the Chiv steam folder, and select High Peformance Processor for it.



  • @venomblade:

    Right click your desktop, go to Nvidia Control Panel, go to Manage 3D settings. Follow instructions in the pic shown here. So make sure to locate CMW.exe in either 32bit or 64, whichever you play in the Chiv steam folder, and select High Peformance Processor for it.

    That only works for NVidia GPUs on a Laptop with OptimusTechnology or Dual Video cards.

    There are lots of options for tweaking and optimizing the game and your PC. Check my signature for links to what I have done.



  • @Retsnom:

    That only works for NVidia GPUs on a Laptop with OptimusTechnology or Dual Video cards.

    There are lots of options for tweaking and optimizing the game and your PC. Check my signature for links to what I have done.

    Being that his CPU has a built in Intel HD 4000, also with his dedicated 670M, and with Chivalry having been known to default to the integrated GPU causing performance issues in the past, only remedied by the method I stated before, I only assumed it was the case as now the game uses CMW.exe instead of UDK.exe so if the person did this process of making the game use its dedicated GPU before, they’d have to do it again now that the game is using a different executable. Would also explain why this just happened after this past update.



  • It seems to be working, but only 50% success. I changed the udk.exe to cmw.exe. Although running UDK.exe would still call the NVIDIA processor to take over (but it was not forced, I let the application decide )

    The new executable seems to be working but not perfectly. The FPS still does drop on 32p servers. Thanks for your suggestions and input guys. I can only keep trying various methods, but it still is buggy wherever I try to make changes.



  • Do you use the newest drivers? That solved the problem for me.



  • Always keep them updated. Maybe an issue with the latest driver.



  • Also try disabling the steam community.

    I play without but on the beta I have it active and it costs me ~20 FPS.



  • No still no improvement. The problem still persists and I’m pretty sure the patch has screwed something up. I simply cannot get a constant FPS while in combat. It still drops to 13-15 FPS sometimes.



  • There are many things that happen that drops FPS. Open spaaces where you can see far into the distance you should notice an FPS drop. Also, then more players there are on a server the more info is being sent through the net code and more your gpu has to render. Combine those two you yes FPS will drop.

    You will probably not notice a drop if there are only 10 players on the server. But double that and the FPS drops big time. The more players that are withing your actual view the more it will slow down. So just think about all that is happening in just two people going at it. Now times that by 10 thus 20 guys going at it and you PC producing all the animations based on what the net code tells your PC to render.

    You can reduce the level of player model rendering with this command in the UDKEnigine.com
    Default BoostPlayerTextures=3.0
    Try BoostPlayerTextures=1.0
    or BoostPlayerTextures=0.5

    That is just one of many tweaks that may help out



  • Might try this one out, thanks Retsnom



  • same Problem here.

    CPU: i74770 3,4ghz
    RAM: 16gb DDR3-1600
    Graka: Gtx 760

    Game Drops to 20fps or maybe lower on Darkforest, Hillside, Citadel, Battlegrounds since the patch from okt. last year. No technical tricks help.



  • I think its a Problem with the Ut3 Engine. Red Orchestra 2 had the same Problem. Tripwire makes a patch and all Players loose 30fps, one months later Tripwire fix it with another patch and all Players gains her 30fps.



  • Problem is not more. i fix this with more power Output of my graka.

    now 62fps without Drops.


Log in to reply