Insane pings when playing this game



  • Sometimes when I play Chivalry I suddenly get a ping of 240 from my usual 20-40 in the middle of a match. I am not running wireless or anything and my internet is good and this only happens when I play chivalry. If I ping google with cmd when this happens I also get the 200+ ms pings on google however if I close the game everything will turn back to normal and my google pings at 6ms again.
    My pc is also good and there are no odd things with the framerate.

    So does anyone else have this or even better know the solution?


  • Developer

    If you have a router, can you try without? If you have multiple network adapters, can you try a different one? If you’re on wireless, can you try with an ethernet cable?



  • I only have one wired network adapter namely the one on my mobo, so yea I am using wired, Changing cables also won’t be an option the way they are layed out and I cannot connect directly to the modem because of the way my router splits telephone television and internet so there is that.

    The only reason I am posting about it is because its a problem unique to Chivalry and closing chivalry immediately fixes my ping on google as well. I don’t always get it so it but when I do closing chivalry is the only way to fix it.



  • As voice and video usually have the highest priority compared to other traffic. Is there perhaps someone watching TV or using the phone when you get the increase in ping? I know that one of my pals ping spikes when his parents watch TV.



  • Nah I think I found the problem, I can trace it back to some custom map with a healing pool in the middle for the classic duel mode (dueling in ffa) and outside of that I have not got it anymore so I think its just a stupid custom map doing it wrong or something.



  • @qlum:

    Nah I think I found the problem, I can trace it back to some custom map with a healing pool in the middle for the classic duel mode (dueling in ffa) and outside of that I have not got it anymore so I think its just a stupid custom map doing it wrong or something.

    No oasis hate! Best FFA Duel map I’ve seen so far. (sorry to whoever made the one with the 6 circles…)


  • Developer

    http://steamcommunity.com/sharedfiles/filedetails/?id=216253827 ?

    I guess it’s possible it’s doing something funky networking-wise that might have confused/overloaded some of your hardware, I could take a look. Doesn’t seem too likely though.



  • Hmm I played some more on that map and now I had no issues, maybe it is something else. All I know that its chivalry or chivalry in combination with something else, maybe a minor mod, I think I need to trace back my steps when it happens again, maybe that will solve it.

    Now that I think of it it could also be the combination of running chivalry while downloading on the background from usenet while I have not had issues with this in the past downloading at 7MB/s does sound like a potential problem.

    Either way I think its on to me to see what runs when it happens again.



  • One definitive way to find out would be to download a network sniffer (such ethereal/wireshark or whatever they’re calling it these days) and run a trace to see what’s happening with your network connections when you get laggy problems.

    Additionally when the issues occur, you could try tabbing out of game and tracerouting the IP of the server; at least it will tell you if the latency is on the first hop or somewhere deeper in the network (in which case it’s likely an ISP routing overloading :P issue)



  • Strangely enough Just as sudden as the problems rose they went away so I have not had this problem ever since.


Log in to reply