[RESOLVED] CMW.exe has stopped working (64 bit)



  • 32 bit works fine, 64bit does not. I was playing on 64bit yesterday until steam went offline for repair and now today I cannot boot chivalry up in 64 mode. I have reinstalled chivalry, updated directX, updated GPU drivers, etc.

    DxDiag and Launch texts uploaded. Important bit from launch log:

    [0020.99] Warning: Warning, Failed to load 'Class None.': Failed to find object 'Class None.'
    [0020.99] Warning: Warning, Failed to find object 'Class None.'
    [0020.99] Warning: Warning, Failed to load 'Class None.': Failed to find object 'Class None.'
    [0020.99] Warning: Warning, Failed to find object 'Class None.'
    [0020.99] Log: Read config file: ..\..\UDKGame\Cloud\CloudStorage.ini
    [0020.99] DevDlc: Shipping Level: AOC-UDKFrontEndMap
    [0021.01] Log: LoadMap: AOC-UDKFrontEndMap?Name=Player?Team=255
    [0021.02] DevDlc: Shipping Level: AOC-UDKFrontEndMap
    [0022.84] Log: Game class is 'AOCEntry'
    [0022.86] Log: !!!!!!!!!!!!!!!!!!!!!!!!!!   CPU skinned AOC-
    
    UDKFrontEndMap.TheWorld:PersistentLevel.SkeletalMeshActor_1.SkeletalMeshComponent_3 CHV_TornBanner.Mesh.SK_Torn_Banner_Flag_pPlane1 1 0 
    
    1 0
    [0022.86] Log: Primary PhysX scene will be in software.
    [0022.86] Log: Creating Primary PhysX Scene.
    [0022.87] Log: Bringing World AOC-UDKFrontEndMap.TheWorld up for play (0) at 2014.02.19-14.57.05
    [0022.88] Log: Bringing up level for play took: 0.033701
    [0023.60] DevSteam: ReadUserStats(76561198094108229) called with result 1 code 1
    [0023.60] Log: Current focused movie? SWF.GeneralManager
    [0023.60] Warning: Warning, Failed to load 'SwfMovie UDKFrontEnd.udk_ime': Failed to find object 'SwfMovie UDKFrontEnd.udk_ime'
    [0023.60] Log: GFx attempted to load missing object [UDKFrontEnd.udk_ime]
    [0023.60] Log: ########### Finished loading level: 2.587486 seconds
    [0023.60] DevSteam: ReadUserStats(0) called with result 1 code 8
    [0023.60] Init: Game engine initialized
    [0023.60] Log: Initializing Engine Completed
    [0023.81] Log: >>>>>>>>>>>>>> Initial startup: 23.81s <<<<<<<<<<<<<<<
    [0023.84] DevSteam: ReadUserStats(76561198094108229) completed with result '1' k_EResultOK (success) and took 959ms
    [0023.84] DevSteam: ReadUserStats(0) completed with result '8' k_EResultInvalidParam (a parameter is incorrect)
    [0023.84] Log: !!!!!!!!!!!!!!!!!!!!!!!!!!   CPU skinned AOC-
    
    UDKFrontEndMap.TheWorld:PersistentLevel.SkeletalMeshActor_1.SkeletalMeshComponent_3 CHV_TornBanner.Mesh.SK_Torn_Banner_Flag_pPlane1 1 0 
    
    1 0
    [0023.85] DevSteam: ReadUserStats(0) called with result 1 code 8
    [0023.85] DevSteam: ReadUserStats(0) called with result 1 code 8
    [0023.85] Log: Read config file: ..\..\UDKGame\Localization\INT\AOCUI.INT
    [0023.95] Log: Read config file: ..\..\UDKGame\Localization\INT\AOCGame.INT
    [0023.98] Log: Read config file: ..\..\UDKGame\Localization\INT\AOCKeybinds.INT
    [0024.00] Log: Read config file: ..\..\UDKGame\Localization\INT\AOCCustomization.INT
    [0024.03] Warning: Warning, Failed to load 'SwfMovie SWF.ProfileMenu': Failed to find object 'SwfMovie SWF.ProfileMenu'
    [0024.03] Log: GFx attempted to load missing object [SWF.ProfileMenu]
    [0024.03] Warning: Warning, Failed to load 'SwfMovie SWF.ProfileMenu': Failed to find object 'SwfMovie SWF.ProfileMenu'
    [0024.03] Log: GFx attempted to load missing object [SWF.ProfileMenu]
    [0024.20] DevSteam: ReadUserStats(0) completed with result '8' k_EResultInvalidParam (a parameter is incorrect)
    [0024.20] DevSteam: ReadUserStats(0) completed with result '8' k_EResultInvalidParam (a parameter is incorrect)
    [0024.23] DevSteam: ReadUserStats(0) called with result 1 code 8
    [0024.23] DevSteam: ReadUserStats(0) called with result 1 code 8
    [0024.23] DevSteam: ReadUserStats(0) completed with result '8' k_EResultInvalidParam (a parameter is incorrect)
    [0024.23] DevSteam: ReadUserStats(0) completed with result '8' k_EResultInvalidParam (a parameter is incorrect)
    [0024.25] DevSteam: ReadUserStats(0) called with result 1 code 8
    [0024.25] DevSteam: ReadUserStats(0) called with result 1 code 8
    [0024.25] DevSteam: ReadUserStats(0) completed with result '8' k_EResultInvalidParam (a parameter is incorrect)
    [0024.25] DevSteam: ReadUserStats(0) completed with result '8' k_EResultInvalidParam (a parameter is incorrect)
    [0024.26] DevSteam: ReadUserStats(0) called with result 1 code 8
    [0024.26] DevSteam: ReadUserStats(0) called with result 1 code 8
    [0024.27] DevSteam: ReadUserStats(0) completed with result '8' k_EResultInvalidParam (a parameter is incorrect)
    [0024.27] DevSteam: ReadUserStats(0) completed with result '8' k_EResultInvalidParam (a parameter is incorrect)
    [0024.28] DevSteam: ReadUserStats(0) called with result 1 code 8
    [0024.28] DevSteam: ReadUserStats(0) called with result 1 code 8
    [0024.28] DevSteam: ReadUserStats(0) completed with result '8' k_EResultInvalidParam (a parameter is incorrect)
    [0024.28] DevSteam: ReadUserStats(0) completed with result '8' k_EResultInvalidParam (a parameter is incorrect)
    [0024.34] DevSteam: ReadUserStats(0) called with result 1 code 8
    [0024.34] DevSteam: ReadUserStats(0) called with result 1 code 8
    [0024.35] DevSteam: ReadUserStats(0) completed with result '8' k_EResultInvalidParam (a parameter is incorrect)
    [0024.35] DevSteam: ReadUserStats(0) completed with result '8' k_EResultInvalidParam (a parameter is incorrect)
    [0024.35] DevSteam: ReadUserStats(0) called with result 1 code 8
    [0024.35] DevSteam: ReadUserStats(0) called with result 1 code 8
    [0024.35] DevSteam: ReadUserStats(0) completed with result '8' k_EResultInvalidParam (a parameter is incorrect)
    [0024.35] DevSteam: ReadUserStats(0) completed with result '8' k_EResultInvalidParam (a parameter is incorrect)
    [0024.36] DevSteam: ReadUserStats(0) called with result 1 code 8
    [0024.37] DevSteam: ReadUserStats(0) called with result 1 code 8
    [0024.37] DevSteam: ReadUserStats(0) completed with result '8' k_EResultInvalidParam (a parameter is incorrect)
    [0024.37] DevSteam: ReadUserStats(0) completed with result '8' k_EResultInvalidParam (a parameter is incorrect)
    [0024.38] DevSteam: ReadUserStats(0) called with result 1 code 8
    [0024.38] DevSteam: ReadUserStats(0) called with result 1 code 8
    [0024.39] DevSteam: ReadUserStats(0) completed with result '8' k_EResultInvalidParam (a parameter is incorrect)
    [0024.39] DevSteam: ReadUserStats(0) completed with result '8' k_EResultInvalidParam (a parameter is incorrect)
    [0024.42] DevSteam: ReadUserStats(0) called with result 1 code 8
    [0026.50] Log: Closing by request
    

    Thanks for the future help.


  • Developer

    This one isn’t a crash log (note the [0026.50] Log: Closing by request). Are there any .dmp files in there?



  • There are but none that were modified today. It says closed by client due probably because it forces me to close it out, as the image shows.

    EDIT: Nevermind I see it does not make a log during a crash.


  • Developer

    Only 64bit fails, no .dmp in Documents/My Games/…

    Do you have any programs running that put up overlays? Alternatively, can you try disabling the Steam overlay?



  • @CrustaceanSoup:

    Only 64bit fails, no .dmp in Documents/My Games/…

    Do you have any programs running that put up overlays? Alternatively, can you try disabling the Steam overlay?

    Welp, after disabling steam overlay 64 bit works. Any ideas on why this has just started? Or how to correct it? I don’t mind troubleshooting ways.


  • Developer

    Any other overlay software? We’ve had reports of the game crashing when you have Steam Overlay plus something else in 64-bit. Not everything else; we use Shadowplay in the office and it has an overlay that doesn’t seem to cause problems.

    As to why it just started:

    Maybe a Steam client update?

    Chivalry’s rendering hasn’t changed, but we have renamed the game’s executable from UDK.exe to CMW.exe for the sake of driver detection. It may be that the different driver profile is throwing things off.



  • @CrustaceanSoup:

    Any other overlay software? We’ve had reports of the game crashing when you have Steam Overlay plus something else in 64-bit. Not everything else; we use Shadowplay in the office and it has an overlay that doesn’t seem to cause problems.

    As to why it just started:

    Maybe a Steam client update?

    Chivalry’s rendering hasn’t changed, but we have renamed the game’s executable from UDK.exe to CMW.exe for the sake of driver detection. It may be that the different driver profile is throwing things off.

    Here’s a list of my processes. Displayfusion and nvidia geforce both have some overlay to them; I’,ll attempt disabling and retrying on a few programs while steam overlay is on.



  • ambfxgen was the problem. The process is for the Mad Cat gaming lights. Although it does not have any overlay that is noticeable, it’s definitely the issue. Thank you for the support! Is there anything you would like for me to do to help you out finding the core problem? I am content with playing with it off.


  • Developer

    @AmishInsurgent:

    ambfxgen was the problem. The process is for the Mad Cat gaming lights. Although it does not have any overlay that is noticeable, it’s definitely the issue. Thank you for the support! Is there anything you would like for me to do to help you out finding the core problem? I am content with playing with it off.

    Ah, not right now, that’s pretty useful to know on its own. Thanks.



  • Same problem, my 64-bit version doesn’t work anymore, crashes instantly upon running


  • Developer

    Please provide a log just like the OP did.


Log in to reply