Downloading required package failed



  • HI i own a server and run custom maps on it and i would like to ask as many players are complaining to me why they cant join some custom maps?For an example i change to wolfslair custom map and they get this error:downloading required package failed.It happens kind of often that players are not able to download a custom map even when they have it downloaded.I cant find any solution for them how to bypass that.Any ideas?That error mantioned above is the main cause for them not be able to join maps.


  • Developer

    Is this limited to Wolf’s Lair, or is it happening on other maps as well? Does this happen to every player? Have you tried deleting the .cmwsdk file for Wolf’s Lair on the server and redownloading it? Have they tried deleting the .cmwsdk file for Wolf’s Lair, or even the whole CookedSDK directory?

    If you can, a sample of a corrupt .cmwsdk file (from the server or a client) that’s causing issues would be helpful.



  • I have tried everything.I deleted all files from my server and uploaded it again told them to join same error appeared.I also tried to guide them how to delete all the custom maps that they have in CookedSDK directory and download that map from my server again same error they get.It doesnt happen only on Wolfslair but also ont other maps like Whitenest or Fourcorners.It happens to different players not just one.for an example i got four custom maps on my server one player gets that error on just one map and he can join other maps without any problems.Another player can join two maps but he cant join others.Also have about 4 players that i know who reports me that they cant join at all to any custom map they want because of that error.Got one players who got that message too but after two days no problems.iIgot about 15 cases when players telling me that they cant join because of that error and those once are the one i know.Iam not talking about how many players just dissappear from my server during a map change to custom map and cant tell me they got that error because they dont know me.


  • Developer

    Client and server logs might be useful.

    The only thing I can immediately think of is that it might be because one of the maps got updated, but the server hasn’t been yet; in that case, restarting the server would fix it as that makes it autoupdate. We’re going to be hosting more Official SDK content servers so we’re going to hopefully see if there are any issues.



  • does each patch break custom maps?

    cause if it does, that’s kinda gonna mess with the progress of modding isn’t it?

    it would be neat if this didn’t happen cause its really gonna mess up all the custom servers running custom content, if you cant get your server back up after a patch because of this,
    ie: the map maker just forgets about that map or no longer works on it.

    any way to over come this problem?

    I had 3 custom maps on my server before yesterday, now im forced to remove them because of this patch, that’s kinda not fair lol.


  • Developer

    Every patch doesn’t break custom maps. That’s one of the nice things about our approach. Even mods that aren’t extremely complex don’t break between patches (Giant Slayers survived the last patch for instance. Chiv+ generally doesn’t because it covers quite a bit more ground and modifies more of the code; GS is not very large)

    Wolfslair broke because it tried to bypass the GUID generation system, which caused issues with recent validation changes. “Grail” and variations had (has?) some odd level streaming issues.

    I don’t know what other maps broke for you, but we test a few random ones every patch to make sure nothing’s broken and things have been okay. It would be useful to know of any breaking issues, please keep us informed. Again, logs from the client and server are very handy for us, we have copious amounts of logging around the SDK system.



  • wolflair was broken in version 1.5 on the latest patch.
    Version 1.6 is working (I know, am running a 50 slot version :P)

    look here: http://steamcommunity.com/sharedfiles/filedetails/?id=233487871

    or you could probably try grabbing crushed on steam. he’s a good guy


Log in to reply