Default Chivalry Map Music



  • Is there any possible way to turn off the default chivalry map music playing in the background? I find it annoying when it is playing through when you have your own custom soundtracks playing, or even other chivalry soundtracks.
    :confused-new:



  • in your sound options it says persistant map music?

    turn that too off should do the trick right?



  • Not what I meant, but thank you. I mean like in the editor, is there a certain option you can set for whether or not that map plays the default music? :saturn:



  • Bump
    /10char



  • Bump.

    Still need help on this.



  • Devs, I am in need of help on this. :frown-new:



  • In World Info menu search for “Disable Jukebox” or something like that.



  • @Ferum:

    In World Info menu search for “Disable Jukebox” or something like that.

    I tried that too, it did nothing.



  • Curious. Worked for me. Does the music still play with jukebox disabled after you cook your map? If I recall correctly the music played in the editor regardless of settings, but in game in cooked map it was fine.



  • @Ferum:

    Curious. Worked for me. Does the music still play with jukebox disabled after you cook your map? If I recall correctly the music played in the editor regardless of settings, but in game in cooked map it was fine.

    I have noticed it does in fact it does play cooked and ingame. I’ll do some more looking.



  • Problem still persists after map being cooked, devs I still need help. Jukebox disabled doesn’t do anything; the map still plays default chiv map music after it’s cooked and ingame.



  • @Pebble:

    Is there any possible way to turn off the default chivalry map music playing in the background? I find it annoying when it is playing through when you have your own custom soundtracks playing, or even other chivalry soundtracks.
    :confused-new:

    I would love to know if this is possible possible as well.



  • Bump, I really need a solution to this, haven’t found one yet. Disabling Jukebox in worldinfo doesnt do anything.



  • hmm ….

    I thought that disable Jukebox in world properties… map properties should work

    if it sdoesn’t work that’s another of 1000 bugs :D

    hopefuly they will fix one day



  • I have jukebox disabled on mine.
    Inside of the editor, the music plays if I have music volume turned up.
    I think it also plays in the actual cooked map.



  • Mipu found the solution to this, you have to add _p at the end of the mapname, worked for me. :topsy_turvy:



  • @Pebble:

    Mipu found the solution to this, you have to add _p at the end of the mapname, worked for me. :topsy_turvy:

    wohoooo am glad it works :)

    btw it was not me but KingJoff who found solution, so thank him
    I couldn’t vote my map on server and he adviced me this _p hotfix
    and my map was instead 26 MB after cooking 47 MB so that “_p” is doing some magic here :D



  • Thank you too KingJoff



  • My map has always had _p at the end, disable jukebox has been checked since the first few days of development, yet the music plays no matter what. An easy way of testing is turn the music right up.
    Even on maps that have their own music, the music doubles up, yet their jukebox is also disabled.
    I haven’t looked into it too much to find out why it always plays, but i’m sure it’s something simple.

    Pretty sure I need to put a node in Kismet that is activated on startup to play audio track, but it plays nothing. Hence no music.



  • @Otreum:

    My map has always had _p at the end, disable jukebox has been checked since the first few days of development, yet the music plays no matter what. An easy way of testing is turn the music right up.
    Even on maps that have their own music, the music doubles up, yet their jukebox is also disabled.
    I haven’t looked into it too much to find out why it always plays, but i’m sure it’s something simple.

    Pretty sure I need to put a node in Kismet that is activated on startup to play audio track, but it plays nothing. Hence no music.

    hmmm…

    and do you have problem with doubled music also online? and what does it do in SP “open map”?

    Play Sound action wokrs well in standard UDK
    though I have not tested it in CMW UDK…


Log in to reply
 

Looks like your connection to Torn Banner Forums was lost, please wait while we try to reconnect.