BSP and landscape losing their material when cooking?



  • Hi! I’m currently building a map for Chivalry, and I’m in the blocking phase of it. When playing and editing in UDK everything looks correct, but after cooking it and playing it in Chivalry, all my BSP and the terrain has the standard UDK tile material. Static meshes retain their materials just fine. Is there any part of the cooking or building process that I’ve missed?

    Thanks!



  • Are you using custom materials on your landscape / bsp? If so where are they stored?



  • Are you building lighting/geometry in the SDK before you cook the map? To do this you select the ‘Build All’ option from the build menu.
    Are you using Terrain? or Landscape? Terrain is a legacy feature and should not be used.
    Are you using the same material for BSP and your landscape? If so, try using different materials to see if it is still happening.



  • @NATO:

    Are you using custom materials on your landscape / bsp? If so where are they stored?

    All assets are from the standard Chivalry setup of materials, meshes etc

    @Lucas:

    Are you building lighting/geometry in the SDK before you cook the map? To do this you select the ‘Build All’ option from the build menu.
    Are you using Terrain? or Landscape? Terrain is a legacy feature and should not be used.
    Are you using the same material for BSP and your landscape? If so, try using different materials to see if it is still happening.

    I’m building everything and using Landscape., and the BSP and landscape are using two different materials (m_grey and 256-256_TILED_WALL)



  • I found the issue, if anyone else experiences the same problem: Some materials seem to survive cooking and other don’t, to me it seems random. All materials saved in a new package, however, will work. Creating your own materials and saving them in a new package seems to be reliable.



  • This is due to the usage flags in the materials. If you noticed you were probably being asked to save certain packages that came with the game before closing the editor. It was because you were applying the material to an object it wasn’t ever used on by the devs so the usage flag never got ticked. Creating the materials in a new package of your own allows the editor to set those usage flags and save them properly so that should always work. The usage flags are the “Used with static meshes” “Used with BSP” and lots of other flags in the materials properties. You don’t need to set these manually as the editor does it automatically but it can’t actually save the changes to the cooked packages if your using the stock content.


Log in to reply