Server delisting itself from server list



  • Hey guys I have this weird issue where my server delists itself from the serverlist and I can’t query it either. I can still direct connect to it though. This happens after about 12 hours. I have to restart the server to get it to show up again.

    launch.log: http://pastebin.com/JJRE2wVG
    game config: http://pastebin.com/5W20uXsf
    engine config: http://pastebin.com/wLuGZPbb

    I don’t think it’s a port issue because I have a dedi box and I tried turning the firewall off and it still does this.
    Here is my commandline AOCLTS-Frigid_p?steamsockets?Port=$[Service.GamePort] -maxplayers=$[Service.Slots] -multihome=$[Service.IpAddress] -QueryPort=$[Service.QueryPort] -seekfreeloadingserver
    If anyone could help that would be great.
    Thanks



  • I have too run into this problem but have not figured it out. Have to kill the server and restart. This happens from both the desktop and also through an admin panel like UGCC…

    what has worked for me is by going into engine file and changing anything with a port to a set port but not default…

    so like

    28000
    28001
    28002
    and so on…

    i did this for all my servers regardless if they were or were not on the same ip which several are…

    Search “port” (24 hits in 1 file)
    C:\servers\chivalry2\UDKGame\Config\DPG1\PCServer-UDKEngine.ini (24 hits)
    Line 12: Port=24000
    Line 13: PeerPort=24002
    Line 460: ServerBeaconPort=24003
    Line 461: BeaconPort=24004
    Line 611: ListenPort=24005
    Line 641: LanAnnouncePort=14001 — not changed…
    Line 647: LanAnnouncePort=14001 — not changed
    Line 675: SystemLinkPort=24007
    Line 891: ListenPort=80 — not changed
    Line 920: UDKRemotePort=41765 — not changed
    Line 921: UDKRemotePortPIE=41766 — not changed
    Line 1032: QueryPort=24006



  • Ok thanks, I’ll try that and see if it helps.



  • What I have found is to just join your server, then have a few friends join in on you. For some reason it will take about 10 mins or so but the server will show up with players on it. I am not sure why this works but once it shows it will show till you restart it or is crashes.


Log in to reply