Having problems with custom content….



  • Ok been going at it for the last few days with a new server rented from NFO.

    I have tried -sdkfileidxxxxxxx in the command line but that failed.

    I have tried creating a .bat file and adding ?chiv.bat to the command line but I am guessing my syntax in the bat file is wrong.

    I have tried uploading the files from my computer to the server. From the :
    D:\SteamLibrary\SteamApps\common\chivalrymedievalwarfare\UDKGame\CookedSDK__CMWSDKFiles

    to

    Server…/UDKGame/CookedSDK/__CMWSDKFiles

    I am trying with another FTP client in hopes that the files will upload correctly but they are not through FireFTP.

    IF there is a solid way of getting the server to also goto the Steam Workshop to keep the files updated that actually works. Please let me know.

    And for some reason I cannot manually load a map from console.



  • I don’t know how NFO does things, but if I recall right, isn’t it -sdkfileid=xxxxxxx
    You forgot the = symbol



  • Yeah but that still isnt working… So I uploaded the maps from my PC to the server and many seem to be working as I go through and test each one but now it seems that there are some missing textures and some maps just crash the server.



  • Might wanna make a ticket with NFO, see if they have a method for custom content.



  • @Raizio:

    Might wanna make a ticket with NFO, see if they have a method for custom content.

    Or just buy a server from SimRai.



  • @rumpelstiltskin:

    Or just buy a server from SimRai.

    I didn’t wanna sound too biased or too much like a salesman.



  • Seriously if you rent a server from simrai then Raizio becomes your personal slave 24//7. You need to put custom maps on your server? Don’t worry, he’ll take care of that or help you.



  • @rumpelstiltskin:

    Seriously if you rent a server from simrai then Raizio becomes your personal slave 24//7. You need to put custom maps on your server? Don’t worry, he’ll take care of that or help you.

    It’s true, pay me and I become your bitch.



  • did you get it worked out Retsnom?



  • I got some of them working others not at all. but I havent tested them yet with the patch release….



  • Retsnom, what exactly did you do to get them to work? I’m pulling my hair out over here with my own NFO server. As much as I would love to switch to SIMRAI for convenience the closest server they have to me is Chicago according to their listing, which is unacceptable concerning ping.



  • @Fisticuffs:

    Retsnom, what exactly did you do to get them to work? I’m pulling my hair out over here with my own NFO server. As much as I would love to switch to SIMRAI for convenience the closest server they have to me is Chicago according to their listing, which is unacceptable concerning ping.

    Where would you like us next?



  • If you can pull something off in the Dallas area you’d have a new customer. NFO has the worst support team in history; I’m usually not one to bash a business, but I have been re-forwarded the same link twice (Torn Banner’s custom content link) in response to 2 separate support tickets, detailing that I have ALREADY seen the link and it does not function as such on an NFO server.



  • I have been super happy with NFO and their support. The problem is not the servers but Chivalry and the steam workshop. I have gotten more maps uploaded and running but not all of them. Several maps are simply broken due to Steam Workshop. If I remove all of the maps, the servers run solid as a rock.

    The problem is that I dont know which map or mod if fucking with the game files. Usually I get an error with shaders files needing to be rebuilt. This is a CHIV / SDK / Workshop issue. The workshop is giving incomplete or corrupt files and or the SDK has issues. Either way maps that worked perfectly before a few patches ago no longer work at all like Cave hide out.



  • Your former posts helped me get it figured out rets; still though it would mean I have to update everything myself whenever chiv updates. Just inconvenient. >:(



  • I agree, thanks Rets, Kila-baine over on steam referred me to KILA for help with this, and your instructions were spot on!

    `Jack



  • its weird how some maps work after a patch and some custom maps don’t.
    also Retsnom some maps don’t have the _p after the name, don’t know if admins knows that or not.:)

    It really kills the modding community and custom servers if every patch every single custom map has to be updated each time.

    I wish there was a way around this.

    what gets me is why and how does a game patch affect a custom map any how?

    I think the patches should auto update the maps to eliminate this process and not break the custom servers, requiring the admins to take those maps out and wait for the creators to repatch them.

    or play the dumb guessing game of finding out which map is breaking your map list, that takes a lot of time and testing, something which admins already do plenty of on modded servers.

    its enough to have to redo mods, but custom maps too?
    that should be fixed by the game patch imo if its possible for that to happen.


Log in to reply