[Problem] Spawn Kill Objective NPC, cannot be killed

  • Hello everyone!

    I am doing the tutorials for AOCTO and I’ve been stuck for more than two hours on the same thing:
    the Spawn Kill Objective NPCs (Villagers) I spawn cannot be damaged/killed.

    Things I have tried so far:

    • Changed faction on the NPC and play on different teams.
    • Put the Example Map’s Kismet side-by-side to my own and compared all the settings for the nodes, yet they are the same.

    It’s like when I hit the Villager the weapon attacks simply won’t collide with it.

    Does anyone have any idea of what this could be? This is really, really furstrating.

    Thanks in advance!

    / Sjonsson

  • Could you copy and paste your Kismet into a text file and post it here as an attachment?

    Also, make sure your PIE game mode in world settings is set to TO and not FFA or something else.

  • Had this problem - i think i solved by this kind of thing…

    what peasant actors have you put in the map are they exactly the same as the stonehill ones or did you create from the content browser - check the physics properties.

    in kismet look at the physics settings in the spawn node.

  • Developer

    Spawn Standard Bot node should have a KillObjective variant that’s easier to use too. The node allows less customization, but has fewer things to potentially mess up or forget.

  • Thank you all for the replies, I have been a bit off the grid and haven’t been able to look at it until now. I checked the game modes and they were correct, the actors I used are the preset ones so I haven’t changed anything about it.

    Lastly I tried spawning a Standard Bot like you said CrustaceanSoup and seemingly it worked.

    Therefore, I decided to simply copy-paste the kismet code from the example map (had no idea I could do this until I tested it now) and it works just fine now.

    I must have done something wrong in the tutorial or missed out some detail, not sure how though - since I did it four times.

    Anyway, thanks for the replised


Log in to reply