Chivalry; router crashes



  • (im dutch btw)
    I won a key, so i installed it on steam; everthing was fine; killed some dudes, but……
    after a day, everytime i join i cant spawn i can spectate for about 10 seconds. All the people in the game freeze; they have a walk animation and i go to the main menu, my internet crashes, my router resets and my internet is after 2 minutes back online, it only happens on chivalry



  • please help me



  • It sounds like your router is being flooded. Do you know what kind of router you’re using, and if you have the latest firmware available?



  • Same thing happens to me BUT only on the 64 player servers. My router is a piece of s*** ( Thomson tg585 v7)



  • i have a speedtouch and i can play cod and bf3 on pc but not chivalry?!



  • I believe Chivalry is far more demanding on your connection because the melee hit detection needs to be so precise. Imagine if every time you shot a gun in an FPS it fired hundreds of bullets in an arc; that’s basically every melee swing in Chivalry.



  • do you think the problem is solved when chivalry is official released (16 oktober) or is the problem only solved when i buy a new router? my parents are gonna buy a new router on the end of oktober so……



  • but in bf3 in a match: they are 64 people; thats far more as is chvalry, so i dont understand why chilvary is harder for my router



  • @Allabonkaja:

    but in bf3 in a match: they are 64 people; thats far more as is chvalry, so i dont understand why chilvary is harder for my router

    It’s not as simple as that, unfortunately - like the guy above said, his router also gets flooded but only on very heavily populated servers. So it’s a matter of scale. The other day Tibberius set the game speed to 120% on the 64 player test server when it was almost filled to capacity, and that was enough to cause a few people to crash who were playing fine before.

    I can’t say with total certainty that a new router would fix the problem, and I can’t say with any certainty that there isn’t a way to fix it without a new router; just passing along the information I have and keeping the thread bumped in case someone who knows of a potential fix sees it. Sorry I can’t be of more help.



  • thank u very much; my parents are gonna buy a new router anyway, what is bumped in forum?? :P



  • @Allabonkaja:

    thank u very much; my parents are gonna buy a new router anyway, what is bumped in forum?? :P

    Posting a response to a thread “bumps” it up to the top of the board. Such as right now. :)



  • NO resolution to this other than a new router possibly? Not a coding issue that cn be resolved. I am also having this issue tonight. I try to get on, server is empty, go back to menu, server list is gone, quit game and cannot get any web pages to come for about 5 min or so.



  • Ok router did not have firmware updated, I have an older router, firmware update , to latest version which unfortunately is 2010 but it is a dlink gaming router, if I am still having issues I will get a new router and update the thread then.


Log in to reply