Battering Ram + TriggerVolume issues



  • So I have been attempting to follow the SDK tutorials.

    So far I have managed to get my battering ram moving using Matinee, however, the AOCTriggerVolumes don’t move with the Battering Ram, despite being Hard Attached with the Base set to the AOCSkeletalMeshActor of the battering ram.

    There are a few other issues as well, but this is the first priority.

    Is there a more up to date or more detailed tutorial than this? Because it feels like I am doing a lot of guess work due to the vagueness of the tutorial :(
    https://tornbannerjira.atlassian.net/wiki/display/CHIVCOM/06-+Making+a+Pushable+Objective#id-06-MakingaPushableObjective-PushVolumeLogic

    Also, I see that AOCObjective_BatteringRam is an actor class, and it is being used in maps within Chivalry, any reason I should/should not use this class?

    Any help would be greatly appreciated.



  • if you have copied the from the example map i believe it should be the battering ram objective - with the battering ram skeletal mesh referenced.

    If their trigger volumes are hard attached, then check that really don’t move when the matinee is played - quite often when you are editing a matinee track the hard attachments don’t update as you go along and edit.



  • Hmmm.

    I haven’t copied from the official maps just yet as I would like to learn how to do it myself so I can create my own unique objectives.

    In the Matinee, the triggervolumes and HUD marker do not move when the battering ram moves (it doesn’t in the example map either). Should I set up a matinee for those as well?

    Also I should note that it appears the triggervolumes and HUD marker are set up correctly, because when I select them, it shows the green box around the base (battering ram).
    I made sure I did all of this before setting up the Matinee for the battering ram too as the tutorial suggests when setting up the base’s after a matinee, problems may occur.



  • So when you run the game in ediror do yhe triggwr volumes move?



  • Nope :(

    I hit F8 to run the game in editor, I spawn, walk into trigger volume, nothing happens, because a TO game hasn’t actually started just yet. So I addbots 1, game starts, I walk into the triggervolume, and the battering ram moves, if an enemy walks into the volume, it stops. So that part works ok.
    However I don’t need to follow the battering ram because the triggervolume stays put unfortunately :(

    When I go into the tutorial map, it works as it should however. I am probably missing something ridiculously simple.



  • I think I just created a new matinee track and moved the trigger volumes that way rather than hard attaching. It’s a little more fiddly but should work.



  • Yeah, I am going to do that Dr Z0b. I did the tutorial again, to no avail, so I dunno, I give up :P
    Of course, the other solution is to just copy the example from the tutorial map and use that and see if that works.

    I just can’t help but feel like I am missing out on one setting that hasn’t been mentioned in the tutorial :(



  • I hard attached the trigger volume and that worked fine for me in my maps.

    You could try to attach the volume through kismet but the normal way to do it though object properties should always work.



  • I ended up copying and pasting from the pushable example into my little test map. I checked out the differences between the triggerVolumes and the only difference I found, was that the base object of the working pushable object is:
    SkeletalMeshActor’AOCTO_testOBJ.TheWorld:PersistentLevel.SkeletalMeshActor_2’

    Where as the tutorial says to use AOCSkeletalMeshActor_0…
    AOCSkeletalMeshActor’AOCTO_testOBJ.TheWorld:PersistentLevel.AOCSkeletalMeshActor_0’

    So I tried to use a SkeletalMeshActor instead…did not make any difference.

    The only way that I have managed to get this to work, is when inside of Matinee, select the HUD object, create a new group, and add a new movement track, but do not record any keyframes as you don’t need to.
    You have to do this with anything that you want to follow the moveable object.

    There must be something I have done wrong though, because when I copy/paste the example objects with hud and collisionvolumes and set up a matinee, they all travel together, no problemo. I am confused :(

    Just to confirm I am doing the right thing.
    This is what I do based on what I have read from the tutorial:

    1. Create AOCSkeletalMeshActor
    2. Create AOCTriggerVolume
    3. Select the AOCTriggerVolume, open it’s properties (F4), and tick “enabled” under the “AOCVolume” section.
    4. Click the little lock symbol to lock the window.
    5. Select the AOCSkeletalMeshActor that I want the AOCTriggerVolume to follow.
    6. Inside of the properties for AOCTriggerVolume, expand the “Attachment” section, and under the “Base” property, click the little green arrow (“Use selected Object in Content Browser”) to assign the AOCSkeletalMeshActor.
    7. Tick the box that says “Hard Attach”.
    8. Open up Kismet.
    9. Select the AOCSkeletalMeshActor.
    10. Inside of Kismet, right click and click New Matinee.
    11. Inside of Matinee, create a new group.
    12. Then create new movement track.
    13. Move the time slider across to say 10seconds.
    14. Move the AOCSkeletalMeshActor and add a keyframe.



  • Create a keyframe, then set it. If you move then set you’re moving the objects staring position and not a key. That probably isn’t causing your attachment issue but still.

    Edit: if you want me to take a look upload it somewhere and I’ll poke around. It’s hard to debug things from a distance like this.



  • I have uploaded the test map to dropbox. There is my first battering ram that has kismet fully set up. If you have a look at the Matinee for it, you’ll see I ended up having to create multiple groups (one for each actor).

    The other battering ram has been set up the same way as what I did in the steps above.
    Clearly I am doing something wrong, because when I copy/paste the collision volumes, hud marker and skeletal mesh actor from the tutorial, they all move together, but I can’t see any real differences in what I have done, compared to the tutorial.

    Here is the .udk file inside of a .rar in dropbox.
    https://www.dropbox.com/s/zk757pvrc6u3c73/AOCTO_testOBJ.rar



  • I made a video to help you.

    Not sure how useful it will be.

    https://www.youtube.com/watch?v=iv-cJY27Pd0

    I’ll look at your map.

    This is bizzare, I can’t find anything wrong with the kismet but the pushable won’t move at all.



  • You can see my dilemma then :P

    I am just going to make do with the work-around I have in place, or I will simply copy and paste a working example from the tutorial map, I just don’t know why it won’t work the way it should.

    By the way, I use the addbots 1 command to start the match, that will make the battering ram move.
    The problem however is if I don’t add new groups in the Matinee for the HUD marker and Collision volumes, then you just need to stand in one spot as the Collision volumes are not moving with the Battering ram.



  • ok looked at your map and the problem seems to be the use of an AOCskeletalMeshActor as your ram, I am not sure why but matinee don’t like it

    Hard attached work and move with normal skeletal meshes AND they work with the normal way of doing this which is to have the skeletal mesh as a component of the AOCObjective_BatteringRAm (find it in actor classes of the content browser and drag it onto your map)

    hope this help



  • Thanks for making me double check the actor MassiveChaos, I kept using the AOCSkeletalMeshActor, even though, I thought in one of my test cases (you will notice I have 2 battering rams there), that I was just using SkeletalMeshActor.

    I identified what I thought might be the problem, I thought I tested my theory correctly, but because of my lack of knowledge with UDK, I ended up still using AOCSkeletalMeshActor….

    I feel like such a nub hahahaha :P

    Thankyou heaps Massive, may not sound like you did much, but you reminded me to triple quadruple check my actor to make sure it was correct :P


Log in to reply