Please, Help! 3 problems (map with all objectives working)



  • Hello.

    I dont know why, but my map worked correctly but suddenly have appeared some errors when I “play on editor window”.

    Problem 1: On the right red mark. Without any blocking volume or mesh or landscape, there is a magical stair that force me to up that (magical stair) and the player cant go througth the map normally.

    Problem 2: On the Red spyral. It’s nearly the same but the player can move normally, but when I atack there is some magical blocking volume that stops the atack.

    Problem 3: Yellow marks. You can’t select this objects. It’s like I pressed “CSG add” with brushes on the air. ¿How I can delete it?

    Thank you in advance!!!



  • Looks like you’ve got all sorts of bsp meshes all over your map. Swap to wireframe mode and look for blue and yellow wireframe. In this view mode you can select and delete them. BSP is used as a simple way to partition space so it can be useful. Unfortunately CTRL+A and CTRL+S create additive and/or subtractive BSP instead of selecting all or saving so if you do that without thinking it you can add these brushes without really thinking.

    Edit: if it’s not that I’d have to take a look at the map locally



  • 1 and 2 > I had a problem with some of the Static Meshes of the game. It seems thats some of them have odd collisions that doesn’t fit the static meshes visual (specialy rocks).

    3 > Already have this issue, in one of my map, a BSP always shows up after loading the map. It was a BSP of stair that I made but even after deleted it, the BSP appear again. I think it’s a UDK bug with complexe BSP. I d’ont have any solution but start over the map.



  • Really thanks!! Nato, the 3 its solved.

    There was like 20 or more BSP blue and yellow meshes all over the map!
    I needed to go to “Brush wireframe” not only Wireframe.

    Only remains the 2nd problem
    I have a lot of meshes apearing and disapearing and matinee movements on this place, it could be just this.

    Thank you all!

    I will inform when I repair all the problems



  • If you have a volume or a trigger in one of those spaces, it could be blocking attacks. Make sure that its collision is set to something that doesn’t collide with weapons.



  • This might be a problem with the landscape itself. If you copied this landscape actor out of other maps it seems that the collision remains the same on it no matter what you change. I’m not sure how to fix it other than creating the landscape from scratch…


Log in to reply