Need Help With Random Freezing/Hiccuping



  • Hello,
    First of all I think this is the wrong section but I cant find the correct one, sorry. Anyways ever since the last update I’ve been getting random freezes while playing, almost like a hiccup. Ill be fighting and all of the sudden it freezes and skips causing me to die. Then it will go back to normal. I was playing Team Fortress 2 and it was kind of happening on that game too but not as bad. All my other games are fine though. I can play Dayz, ARMA, Payday, and every other game I own just fine. My ping isnt the issue its always at 30-70. My FPS is always 60+. I have good internet and my these are my PC Specs: Ripjaw 8gb RAM, i5 4670k, ASROCK extreme 4 mobo and Radeon 7850.

    Ive had this game since release and never had this problem. I would really appreciate help because this game has become almost unplayable. Thanks bye :nevreness:



  • Well the fact that it happened in TF2 under a different engine says that there maybe something wrong with your hardware, aka drivers or an overheating CPU/GPU. I would also check all the obvious, like malware and other programs running in the back ground accessing the net.

    Another thing is that you may have good internet ping wise but if you are not the only one hitting the net at your house, precious bandwidth might be getting sucked up by family, roommates, neighbors stealing wireless.

    OH are you playing wireless, router, mouse and keyboard? There can be interference as well as batteries dying. Check the easy obvious stuff first. Add a QOS to your game via the router so it gets more bandwidth when you play. Check your task manager and see what extra processes are running and if any are sucking up CPU and memory. Try Razor Game booster.

    There is lots to troubleshoot but eliminate the easy simple stuff first.



  • @Retsnom:

    Well the fact that it happened in TF2 under a different engine says that there maybe something wrong with your hardware, aka drivers or an overheating CPU/GPU. I would also check all the obvious, like malware and other programs running in the back ground accessing the net.

    Another thing is that you may have good internet ping wise but if you are not the only one hitting the net at your house, precious bandwidth might be getting sucked up by family, roommates, neighbors stealing wireless.

    OH are you playing wireless, router, mouse and keyboard? There can be interference as well as batteries dying. Check the easy obvious stuff first. Add a QOS to your game via the router so it gets more bandwidth when you play. Check your task manager and see what extra processes are running and if any are sucking up CPU and memory. Try Razor Game booster.

    There is lots to troubleshoot but eliminate the easy simple stuff first.

    All my drivers are up to date, my temps are fine and I dont have any other programs running. My internet is 15mbps down and 2 up. My keyboard, mouse, and microphone are all wired. Im hardwired to my router. I honestly dont understand why this is happening because before the update it was perfectly fine and now its unplayable. I ran a virus scan and nothing came up. I can play almost any other game just fine but this one.



  • Is your OS 32bit or 64 bit?



  • @omg87:

    Is your OS 32bit or 64 bit? How much RAM you got?

    Says 8 in the OP. He could try running chiv in either 32 or 64 bit. Not sure which is default.



  • Thread has been moved.



  • @omg87:

    Is your OS 32bit or 64 bit?

    Win 7 64bit



  • WOW I’m having the same issue! I freeze for maybe 5-10sec then I’m dead. I ask the other people in the server if they experienced an issue and they say no, it’s just me :< It’s far from unplayable, but just REALLY frustrating to have it happen when you’re fighting…and of course, it’s not a very believable excuse for dying :/ I have an AMD card too, XFX 7870 OC 1.1 ghz core clock speed. CPU is AMD FX-8350 OC 4.2ghz. I set my cpu and gpu clock speeds back to default when this issue arose, but it hasn’t made a difference. My OC speeds were fairly conservative, so that’s not the issue…temps aren’t ideal, but nothing to worry about. So happy it’s not just me having this issue!



  • Forcing the game to run at 32bit instead of 64 bit causes a huge performance improvement for me. Definitely worth trying. I wonder if you both have the same antivirus programs? Try completely disabling them when you play and see what happens.



  • @Tyoson:

    Forcing the game to run at 32bit instead of 64 bit causes a huge performance improvement for me. Definitely worth trying. I wonder if you both have the same antivirus programs? Try completely disabling them when you play and see what happens.

    I have avast. Ill try running it at 32 bit.



  • Running in 32bit didnt help :’(



  • Do you guys have cpu throttling such as amd cool and quiet or speedstep active? They’ve been known to cause problems as they try to scale the CPU to save power



  • @MonkeyFiend:

    Do you guys have cpu throttling such as amd cool and quiet or speedstep active? They’ve been known to cause problems as they try to scale the CPU to save power

    It was enabled but I turned it off and still have this issue…



  • Do you have crossfire or sli?

    Go to C:\Program Files (x86)\Steam\steamapps\common\chivalrymedievalwarfa re\Binaries\RedistChiv and run the two vcredist executables.

    If you tab out when the game is stuttering, and open task manager what is your memory looking like?

    I’d also want to check a few other things; stuttering can also be caused by sound issues. So it might be worth disabling your sound card in device manager and try running the game there?



  • @MonkeyFiend:

    Do you have crossfire or sli?

    Go to C:\Program Files (x86)\Steam\steamapps\common\chivalrymedievalwarfa re\Binaries\RedistChiv and run the two vcredist executables.

    If you tab out when the game is stuttering, and open task manager what is your memory looking like?

    I’d also want to check a few other things; stuttering can also be caused by sound issues. So it might be worth disabling your sound card in device manager and try running the game there?

    Just one GPU and the stutter only lasts about a second or two, so it would be hard to check the memory. Like say someone is back pedaling it will show them back pedaling on my screen but then they teleport in front of me and are already swinging. It sounds like just lag but i always have 30-70 ping.

    In the binaries folder theres no RedistChiv folder the only folders are win64 and win32



  • This also has been happening on Counter-Strike GO



  • I’ll try turning antivirus off, and I’ll check out that power saving mode that amd cpu’s have. However, I recently unparked the cores of my cpu and I have each running at a constant 4.2ghz while playing games. My gpu is the bottleneck in my case, but not really too bad (amd 7870, which is a decent card).



  • STill having this problem…. Anyone have any other ideas?



  • How’s your HDD?

    A dieing HDD can cause stuttering.

    Another thing ot look at is your anti-virus, make sure your chivalry directory is excluded. To be sure disable it completely while playing and see if it continues.

    Check your background processes, some poorly programmed programs can cause windows to hand while it does some stuff, make sure you are not running stuff in the background that you don’t need to.

    The current state of Chivalry takes more CPU power than it did 1 year ago. My CPU would do micro-stutters all the time during chiv until I overclocked it from 3.2->3.8ghz. It was just under the capacity to run my system and chiv without maxing, now it runs mostly OK (unless playing Chitadel).



  • @Distortic:

    STill having this problem…. Anyone have any other ideas?

    I’m having the exact same problem as well. I’m quite sure it’s not AVG Antivirus, since i had these problems since the last update, and i only installed that scanner yesterday. It’s not an overload of processes or a firewall problem. I didn’t have the problems before the most recent update, so perhaps that corrupted…something?

    specs: intel core i7 4700MQ CPU @ 2.40 GHz, 8 gig memory, Geforce GTx 765M


Log in to reply