New patch fps drops



  • Of course I’ve had fps drops in the past that have fixed themselves in a couple days, but these are worse and have lasted much longer. Here’s a screen where I was getting consistently bad frames for 15+ seconds (something it just randomly does): http://steamcommunity.com/profiles/76561198085166476/screenshot/598158853746086451

    Fps is on the right along with other stats. Not sure what they mean.

    I have an i7-3630QM 2.4 GHz, 8 GB RAM, and a GeForce GT 635M (just a renamed 555m).

    Can you work your magic Crusty? :D



  • Karasu, do you have turboboost enabled on your chip? ie Are you running it at 2.4ghz or 3.2ghz? Your screenshot says your CPU is working pretty hard, no amount of graphic tweaking will improve your FPS until you sort your CPU out.

    Edit, I’m assuming your running on a Laptop. Have you made sure your power consumption settings are set to performance and not optimal or saving or whatever?

    Doing a quick bit of googling, if your CPU is not overclocking itself with Turbo Boost (which it should automatically) it is most likely due to temperatures being too high. Turbo Boost will only kick in if temperatures are belew a modest threshold for the stock cooler. If there is dust and your in a hot room or something, it wont kick in, giving you crap 2.4ghz speeds. ie 24ms frame times in Chiv.

    Is your ragdolls set to 5?



  • @Toll:

    Karasu, do you have turboboost enabled on your chip? ie Are you running it at 2.4ghz or 3.2ghz? Your screenshot says your CPU is working pretty hard, no amount of graphic tweaking will improve your FPS until you sort your CPU out.

    Edit, I’m assuming your running on a Laptop. Have you made sure your power consumption settings are set to performance and not optimal or saving or whatever?

    Doing a quick bit of googling, if your CPU is not overclocking itself with Turbo Boost (which it should automatically) it is most likely due to temperatures being too high. Turbo Boost will only kick in if temperatures are belew a modest threshold for the stock cooler. If there is dust and your in a hot room or something, it wont kick in, giving you crap 2.4ghz speeds. ie 24ms frame times in Chiv.

    Is your ragdolls set to 5?

    Turboboost was enabled as soon as I got it but I encountered some problems as the temps would shoot up to 93C within seconds of prime 95 being ran. It is a laptop, and because of this heating problem I’ve had to throttle my cpu down to 90 percent. However, awhile ago I was able to play just fine with my cpu throttled to 65 percent and now it’s having trouble on 90.

    Room temp is normal and I frequently clean out dust. Ragdolls are at 3.

    Also playing on minimum settings with 1600x900 resolution.



  • Well, your screenshot clearly shows CPU is running hard (so it GPU, but CPU more).

    Match your resolution down to your monitors native resolution if you can. Type this in console: scale lowend

    Then change your resolution and see if that helps. If it does, increase your graphics bit by bit and let your GPU thread time increase to sit just under your CPU.

    Also have you made the soundmincompress (or whatever it is in the ini) 3 or greater?

    There is also the option of forcing chivalry to use the physical cores of your CPU and not the emulated cores, do this by disabling hyperthreading.



  • Ok so here’s what I’ve tried so far (will try everything you said when I get back from lunch).

    I throttled my gpu as low as it can go. I had a hunch it was heating up my cpu not allowing me to use that as well. When I did this, I was able to turn my cpu up to 99 percent without any heating problems.

    Turned resolution down even further in game. Down 2 options I think (not sure how much that helped). If I match it to my monitor’s resolution then I fear that will be more performance demanding but I will try it. However, I have no idea how to have my gpu thread time sit just under my cpu (I fear that may heat my cpu due to my laptop design as previously mentioned).

    I changed soundmincompress to 4.

    There didn’t appear to be an option for hyperthreading in my bios but I will keep looking.

    After doing all this, I noticed ridiculous improvements on battlegrounds (the worst map for me). I suspect it was being able to use my cpu more now, but I will have screens for this sometime after I eat lunch.


Log in to reply