DEVS: Can't change Xbox controller bindings



  • Hi Devs,
    CMW has never allowed changing the Xbox controller bindings and this needs to be updated.
    I’m not sure if you Devs are aware that changing the bindings in the settings does not remove the default controller bindings, so it’s not possible to change the controller setup at all. Please update this so that controller users can create custom bindings like everybody else.
    Thanks,
    -Steve



  • Sure you can.

    1. Grab Xbox controller cable.
    2. Yank it out.
    3. Plug in mouse.
    4. Done, now you are playing the game properly.



  • Aside of Lemons obvious troll post.
    I play with a 360 controller and I do not use any 3rd party programs. All I’ve ever done is plug in the 360 controller, start up the game, go to keybinds and double click a bind then press the button on your controller you want.
    There are also few things, like sensitivity, that I change in the .ini as well, but that is up to you if you want to change those settings in UDKgame.ini, look for LookUpScale & LookRightScale lines to change the sensitivity

    Don’t let anyone tell you this game cannot work will with a controller, I know a few players who are very successful. Make sure you change your sensitivity and you should be fine with a good setup that works well for you.



  • Well you can use 3rd party software. Its part of remix’x alternate server browser.



  • @lemonater47:

    Well you can use 3rd party software. Its part of remix’x alternate server browser.

    Actually, I cannot get Remixx’s server browser to even work anymore. After the game was updated and no update to the alt browser, it seems to have broken it. Java is up to date, but I think that may be the problem, java is, but not the alt browser.



  • @Goregasm I can bind controller buttons just fine, but the original bindings remain as well. Basically I can double up button bindings, but I can’t ever remove what was already setup. You’re telling me you can make the right trigger do the secondary attack? That never works for me because it is always set to do the primary attack.



  • @stevedoetsch:

    @Goregasm I can bind controller buttons just fine, but the original bindings remain as well. Basically I can double up button bindings, but I can’t ever remove what was already setup. You’re telling me you can make the right trigger do the secondary attack? That never works for me because it is always set to do the primary attack.

    I’ve kept the majority of the buttons the same, but there are a few things I do differently. I’ve made holding ‘X’ my alt attack button, it also is my use and reload key(for archers). ‘B’ is my cancel attack/feint, and my ‘A’ button is jump/dodge, dodge while walking as maa and jump for all other classes, for maa I have to be sprinting to jump. D-Pad right switches from primary to secondary weapons.

    If you want to prevent the default buttons overlapping with custom, you will have to go to:
    Documents\My Games\Chivalry Medieval Warfare\UDKGame\Config

    Open UDKgame.ini in notepad or something similar and find the lines corrisponding to the button you wish to customize. For example, to bind something to the ‘A’ button find this line:
    Bindings(Name=“XboxTypeS_A”,SecondaryKey=,Command=“GBA_Jump|GBA_AOCDodge”,Control=False,Shift=False,Alt=False,bIgnoreCtrl=False,bIgnoreShift=False,bIgnoreAlt=False,Flag=“KBFlag_Movement|KBFlag_Movement”,FriendlyName=“Jump|Dodge”)

    Or to bind something to ‘X’:
    Bindings(Name=“XboxTypeS_X”,SecondaryKey=,Command=“GBA_Reload|GBA_MeleeLeft|GBA_Use”,Control=False,Shift=False,Alt=False,bIgnoreCtrl=False,bIgnoreShift=False,bIgnoreAlt=False,Flag=“KBFlag_Weapon|KBFlag_Weapon|KBFlag_Utility”,FriendlyName=“Reload|LeftAttack|Use”)

    Notice they’re similar lines and they’re all bunched up together so you don’t have to look all over the place.
    To remove the default key/button, look for what button you want to clear out(I’ll use ‘X’ as an example) remove the line between the "(quotes), in my case I’d remove GBA_Reload|GBA_MeleeLeft|GBA_Use and that would free out the ‘X’ button. Save the file, go into your game, double CLICK on the keybind you wish to reassign then press the button you want to assign it to…like normal.

    This will make it so you can bind the buttons the way you want them to be binded without the hassle of having to mess around with the ini too much. However, if you’re going to continue playing the game with a contoller, I’d reccomend learning how to fool with the ini directly so you never have to use the in-game binding. Like you said, the devs haven’t thought it through and they probably never will, these ini settings are changed just about every patch and you will be doing it a lot. This game has PARTIAL controller support, so it’s up to you and people like me to help others with this so that we can thoroughly enjoy the game.

    I hope this helps, I’m not too great with explaining how to mess with the ini…so if you have any questions feel free to continue posting here and I’ll help the best I can.



  • Aside of Lemons obvious troll post.

    I thought it was quite funny tbh.



  • @Flippy:

    I thought it was quite funny tbh.

    Made me laugh, too, but this man needs help!



  • And here we are almost a year later and the devs couldn’t give a crap about helping controller players since the problem remains. The failure to notice detail in this game is why the devs suck.



  • @stevedoetsch:

    And here we are almost a year later and the devs couldn’t give a crap about helping controller players since the problem remains. The failure to notice detail in this game is why the devs suck.

    Firstly, yes you can now apparently many people have after a large bout of complaining that all stopped.

    Secondly, its out on console now anyway.



  • Pretty sure you could change the binds before and now you can’t.


Log in to reply