Chivalry stops responding when attempting to browse for servers



  • Every time I try to browse for servers I have to force close the game because it stops responding. There has been no updates; this just randomly happened. I’ve tried playing in safe mode and 32bit mode. I’ve tried verifying the games, I’ve tried reinstalling. I have even wiped my whole damn computer and put a fresh install of Windows and all my drivers. I don’t get it. I’ve never had an issue.



  • Try these solution:

    1. An anti-virus program is running and blocking required internet traffic from our game to Steam. Ensure that Chivalry is given full permissions through your anti-virus program.

    2. Your router NAT table is being overloaded. You can lower the maximum allowable pings in order to see more servers.
      How to allow for higher pings in Steam.

      1. Run the Steam client.
      2. Navigate to the Steam menu at the top of the window.
      3. Select Settings.
      4. Navigate to the In-Game tab.
      5. Under the heading “In-Game server browser: Max pings / minute” select “Automatic (1500)”

Log in to reply