Getting seriously mad.



  • Guys, I have been having really weird problems lately. People quite often walk off into space as if the server is lagging out, but then it catches back up and everything is fucked up. Happens ALL the time now, half the time with GOOD PING. Am I experiencing packet loss or something?

    Another problem that has been plaguing my Chivalry experience is general inconsistency in animations. I’m sure it’s due to latency, but fuck, man, what can I do? I can’t duel normally anymore, its too painful getting hit whilst everyone is freezing or seeing minor desyncs for 1/3 of the swings. These swings are just faster than the animations or something. Parrying feels very wrong and I can’t play properly. Most of the time my ping seems fine.

    Any advice for tracking down the source of my lag or whatever this is? I suspect that my computer or my laptop next to my PC is downloading shit in the background. Is there a way to find the source of bandwidth eating programs?

    Idk, I don’t have these problems in my other games. Maybe it’s a chivalry thing.



  • 1. Make sure you’re not accidentally seeding any torrents.

    2. If you’re not already connected to your router/modem by an ethernet cable, do that.

    3. If you are already connected by an ethernet cable, check along the entire length of the wire and make sure there’s no damage. Make sure it’s not chewed up, squished or pinched.

    3. Open up the CMD prompt. (WinKey + R) and type, “pathping www.google.com”. It’ll take a couple hundred seconds to finish. Once the test is finished it’ll look like a bunch of jargon to you but there’s a lot of important information in it. Expand the prompt fully vertically and take a screenshot of your desktop. (Prt Scr key). Make sure you’re playing the game while this test is going.

    Then open up Paint and place your cursor inside the canvas. Press Ctrl + F and the image of your desktop should appear. Make sure to cover your IP address with red paint or something before you save the picture.

    Save the picture, upload it to Imgur and then stick it in this thread for me to look at.



  • @Flippy:

    1. Make sure you’re not accidentally seeding any torrents.

    2. If you’re not already connected to your router/modem by an ethernet cable, do that.

    3. If you are already connected by an ethernet cable, check along the entire length of the wire and make sure there’s no damage. Make sure it’s not chewed up, squished or pinched.

    3. Open up the CMD prompt. (WinKey + R) and type, “pathping www.google.com”. It’ll take a couple hundred seconds to finish. Once the test is finished it’ll look like a bunch of jargon to you but there’s a lot of important information in it. Expand the prompt fully vertically and take a screenshot of your desktop. (Prt Scr key). Make sure you’re playing the game while this test is going.

    Then open up Paint and place your cursor inside the canvas. Press Ctrl + F and the image of your desktop should appear. Make sure to cover your IP address with red paint or something before you save the picture.

    Save the picture, upload it to Imgur and then stick it in this thread for me to look at.

    Thanks, will try, but can you tell me what it is first lol? I don’t wanna accidentally give out personal info. XD


  • Mod

    I’ve had huge lag spikes and then realised half an hour later is was my mobile phone updating its apps. Sometimes chivalry workshop decided to update in the background too which also lags me. Sometimes my bloody microwave lags me.

    Are you connected through wifi or ethernet? Strongly recommend ethernet if you can do it. I can’t at the moment which sucks :/



  • @JimmyTryhard:

    Thanks, will try, but can you tell me what it is first lol? I don’t wanna accidentally give out personal info. XD

    What exactly are you referring too? If you mean your IP address, every single electronic device that connects to the internet is given a unique name. This name is called an IP address. There’s a little more to it than that but basically you never want to share your IP address with other people you don’t completely trust. If someone learns what your IP address is, they can DDOS you and make your life sucky.

    And after I typed all that I just realized you probably meant where is it. Once the test is done you’ll see a list of numbers on the left hand side. On the very first hop, to the right of that you’ll see a group of numbers inside brackets separated by periods. Cover that up with red paint or whatever you want. Just make sure people can’t see it in the picture.



  • that’s not going to be his machines IP address, it’s going to be his ISP, they use this thing called NAT so that you’re external IP is different than your internal.

    But dude Jimmy i know exactly what you’re taking about. In game i try not to complain about it but its hard not to. Like i said last week or w/e when we scrimmed i was trying to hold back in the server but i basically typed that i’m lagging and flippy had to get on me because it basically seems like i’m complaining because we’re doing bad or something (which we weren’t) but i understand how it seems to other people that i’m making some excuse.

    But seriously, it’s SOOOO bad for me. I’ve checked my connection through speedtest and pingtest… i’m not getting ANY packet loss, and this shit happens even with like 56 or so ping. Teleports, animations looking totally choppy and skipping around, the actual desyncs i don’t get that much believe it or not, it’s just that the animations are so choppy.

    So for example if a messer or zwei is dragging, i see skips of the drag and it throws off the smoothness of it. Or if a polearm is doing a lookdown feint, i can’t tell that they’re feinting, and even sometimes with those weapons it LOOKS like they DID feint because the weapon animation chops to make it look like it was stopped but it did not stop and it smacks me for like half damage.

    I also get shit where people running or moveing skip a beat so when i;m trying to chase or track a target by aiming, i miss them because they aren’t where their model tells my eyes they are any longer. It’s as if the class maa dodges out of my way’. This is also very annoying if i decide to use throwing weapons or say an archer class with projectiles because i can’t track.

    How are your FPS? Mine suck now.

    I have one last thing i can possibly try because so far i have completely fresh installed my game, uninstalled, removed EVERY configuration and chivalry file from my computer, removed all workshop maps, mods, and shit. And re-installed. I’ve updated my graphics drivers and always did a clean install of these by uninstalling, removing, and re-installing new. I’ve tried the newest driver, an old one that used to work great for chiv, and even some beta drivers. I’ve overclocked, and set my entire CPU and GPU to stock settings and tested stable overclocks overnight with prime95 and gpu benchmarks. I’ve checked all my temperatures and usage percentages at load. I have checked my connection as i said and am getting about 95mbps down and 12mbps upload with 0 packet loss. I’ve done memtests to check my memory, i’ve got 2 4GB sticks so 8 total. And i have a 3770k now @ 4.7Ghz and gtx680SC and Vertex4 SSD. I’ve messed with many settings in nvidia control panel, as well as going back to default on this (also doing this when re-installing the drivers). I’ve also disabled hyperthreading on my cpu (JUST TO CHECK)

    SOOOOOO… with all that being said, i’m pretty sure it’s chivalry and not my computer is causing this shit.
    Why everyone else seems to be unaffected… i have no idea. I’m wondering if they’re not affected or they just don’t know the difference between smooth animations and choppy ones. I know the experienced players do. Some seem to have this issue, and some don’t but i’ve talked to plenty of people that do. It seems more and more people are experiencing this so i don’t know if it’s some compatability issue with hardware or what. All i know is from getting 120fps solid in this game pre-about 10 patches ago, to now getting 40-60fps uncapped… SOMETHING IS WRONGGGGGGGGGG

    https://www.youtube.com/watch?v=gVdEINfm7H4



  • I just did some duels and noticed it too. Animations are considerably harder to read than they used to be because of how inconsistent, studdery, warpy, etc they are. They also hit super early sometimes too.



  • Just open cmd and:ping -t the server ip continously and output it to a file… ping -t 00.000.000.000 >> c:\ping.txt (with 00.000 etc being server ip) for example and after 10-15 minutes just turn it off with ctrl+c in the cmd window.

    If you’re getting packet loss then contact your ISP but ONLY do so after first restarting your router/modem, restarting your computer, replacing any and all ethernet cables between your computer and whatever hooks you up to the internet, try bypassing your router if it’s possible, bypass any other switches, hubs or other network hardware between you and your modem/internet outlet, if you’re on wireless then try using an ethernet cable instead, or you could try going wireless if you are wired and don’t have another cable at hand.

    I would also probably try on a different computer, borrow someones laptop home for an hour or so if you don’t have any of your own.

    Always the best idea to be systematic and check every possibility before you break lose hell on your providers support. They will ask you to do all these things anyway before they even check their own resources for fault.

    I guess the worst thing that can happen is if your network card is at fault, if it works better on another computer I would first re-install your operative system from scratch and if that doesn’t help I would get a new network adapter.

    All I can think of without troubleshooting it myself (which I won’t because of obvious reasons) good luck :P

    EDIT: ofc if you are getting answers with very very high response times consistently or inconsistently it coulld be either your ISP or downloads on your network. I would try to unplug all other network devices but your own computer in this case and see so it’s not a local issue.



  • @50ShadesofClay:

    that’s not going to be his machines IP address, it’s going to be his ISP, they use this thing called NAT so that you’re external IP is different than your internal.

    But dude Jimmy i know exactly what you’re taking about. In game i try not to complain about it but its hard not to. Like i said last week or w/e when we scrimmed i was trying to hold back in the server but i basically typed that i’m lagging and flippy had to get on me because it basically seems like i’m complaining because we’re doing bad or something (which we weren’t) but i understand how it seems to other people that i’m making some excuse.

    But seriously, it’s SOOOO bad for me. I’ve checked my connection through speedtest and pingtest… i’m not getting ANY packet loss, and this shit happens even with like 56 or so ping. Teleports, animations looking totally choppy and skipping around, the actual desyncs i don’t get that much believe it or not, it’s just that the animations are so choppy.

    So for example if a messer or zwei is dragging, i see skips of the drag and it throws off the smoothness of it. Or if a polearm is doing a lookdown feint, i can’t tell that they’re feinting, and even sometimes with those weapons it LOOKS like they DID feint because the weapon animation chops to make it look like it was stopped but it did not stop and it smacks me for like half damage.

    I also get shit where people running or moveing skip a beat so when i;m trying to chase or track a target by aiming, i miss them because they aren’t where their model tells my eyes they are any longer. It’s as if the class maa dodges out of my way’. This is also very annoying if i decide to use throwing weapons or say an archer class with projectiles because i can’t track.

    How are your FPS? Mine suck now.

    I have one last thing i can possibly try because so far i have completely fresh installed my game, uninstalled, removed EVERY configuration and chivalry file from my computer, removed all workshop maps, mods, and shit. And re-installed. I’ve updated my graphics drivers and always did a clean install of these by uninstalling, removing, and re-installing new. I’ve tried the newest driver, an old one that used to work great for chiv, and even some beta drivers. I’ve overclocked, and set my entire CPU and GPU to stock settings and tested stable overclocks overnight with prime95 and gpu benchmarks. I’ve checked all my temperatures and usage percentages at load. I have checked my connection as i said and am getting about 95mbps down and 12mbps upload with 0 packet loss. I’ve done memtests to check my memory, i’ve got 2 4GB sticks so 8 total. And i have a 3770k now @ 4.7Ghz and gtx680SC and Vertex4 SSD. I’ve messed with many settings in nvidia control panel, as well as going back to default on this (also doing this when re-installing the drivers). I’ve also disabled hyperthreading on my cpu (JUST TO CHECK)

    SOOOOOO… with all that being said, i’m pretty sure it’s chivalry and not my computer is causing this shit.
    Why everyone else seems to be unaffected… i have no idea. I’m wondering if they’re not affected or they just don’t know the difference between smooth animations and choppy ones. I know the experienced players do. Some seem to have this issue, and some don’t but i’ve talked to plenty of people that do. It seems more and more people are experiencing this so i don’t know if it’s some compatability issue with hardware or what. All i know is from getting 120fps solid in this game pre-about 10 patches ago, to now getting 40-60fps uncapped… SOMETHING IS WRONGGGGGGGGGG

    https://www.youtube.com/watch?v=gVdEINfm7H4

    Sigh. I hope it’s just a Chivalry thing and it can be fixed. I haven’t done as much further testing as you, as this has been present in the recent past, but until now it was manageable. I play other games, though, and I rarely have problems there. I was playing Red Orchestra 2, Modern Warfare 3 (i know, i know), and other games and it was all smooth and normal. It’s gotten to the point where I don’t even LIKE playing this game unless I am scrimming.

    My FPS seems to be the same as ever. I don’t uncap it or anything, so who knows, maybe my potential FPS has lowered in some way, but I always play on 60 anyway.

    I wonder if there is a bug in their networking system or whatever it is that manages the info that transfers to client and server. I don’t wanna be a TBS whistleblower or anything lol but optimization needs to be their biggest focus.

    I also hate complaining too much but srsly I’m not making excusesssss lol

    There is a possibility that it is just me, and not the game. I am not using ethernet, because I can’t run a cable through 3 doors and across my house at the moment. Maybe I will look into doing that, though. I have only about 15 megabits of connection (3 MB/s down, 1 MB/s up). I can’t even move my modem, because they have to install something into a cable TV outlet to give me internet. I hate the damn monopoly internet companies puts my region through.

    I also use a USB wireless card, a cardinal sin, I know. What do you guys use in your desktop PC’s? I haven’t really had problems in the past with my USB wireless card, but who knows, maybe that is a factor.



  • Oh, by the way, I think my laptop is doing something to interfere with my connection. I usually have it sitting next to my desktop in a basically dual monitor setup, also next to my USB wireless card. I also have a mixamp there too. The strange thing about my laptop is that it’s audio jack seems to fluctuate in it’s output, because when I plug a gold plated 3.5mm to 3.5mm inside the laptop and into my mixamp, I can hear interference (a buzzing sound) depending on where I place the cable. I have to wiggle it about until I can’t hear it anymore. The same buzzing effect comes from my finger touching one end of the cable as well. Maybe all of this interference is messing with my USB card. Could it be static?

    ***Just read up about my specific mixamp. This is a problem with grounding. Could excess energy flow cause interference with wifi signal?



  • I’m not sure how dragged animations only look choppy now. For me they’ve looked choppy as hell since I’ve played this game.



  • in chivalrys defense, all games with ut3 engine cant hold solid 120 fps for me. ut3 just sucks ass in this department, period.



  • @swagfox:

    I’m not sure how dragged animations only look choppy now. For me they’ve looked choppy as hell since I’ve played this game.

    Have you ever been able to read drags? If you never have then you probably won’t notice it.



  • @Tyoson:

    Sometimes my bloody microwave lags me.
    :/

    Time to bust out those tinfoil hats mayne…



  • @swagfox:

    I’m not sure how dragged animations only look choppy now. For me they’ve looked choppy as hell since I’ve played this game.

    +1

    /10fukincharaters


  • Global Moderator

    @Terminally:

    +1

    /10fukincharaters

    I don’t know if you’ve heard but there’s a great new thing called the edit button.



  • @lemonater47:

    I don’t know if you’ve heard but there’s a great new thing called the edit button.

    My time is too valuable to be wasted on edits, I live my life dangerously!



  • only strange glitches I have is when I die in 3rd person view, then the view will like switch back and fourth real fast like 5 times, its weird, and just a couple of times where i could have sworn I got the kill, but died, but who knows, would have to watch a replay or something to verify.

    oh and the getting stuck on hills thing floating there, but that seems common.



  • @Nohbdy111:

    Have you ever been able to read drags? If you never have then you probably won’t notice it.

    well generally I worked around this by watching body movement and not looking at the actual weapon model because that would get me killed half the time. Then I got. 144hz monitor and reading the weapon itself became much more reliable. Drags never worked on me anymore and anything other than facehug feints were ez to read. Then this new camera and going from 120 fps to like 70-80 and I fall for drags every now and then.



  • Stop downloading Taylor Swift albums and gay porn while you play. I turned off all my midget on horse torrents and chiv ran wonderfully.