Please Help! Just A Damsel In Distress…



  • So I have a problem… Let’s start at the beginning… When I first downloaded this game I never EVER had any problems with it at all… Ran real smooth and graphics were crystal clear… Now acouple months ago after a patch it all of a sudden got just really choppy… Tried just about everything now… I know it has nothing to do with my computer and nothing wrong with my internet being that I have a desktop that runs the game fine… Just a girl that’s stuck right now and don’t know what else to do… I love and miss this game :( Please help…

    My Laptop:

    MSI GS70

    Intel i7-4700 2.40ghz
    12 GB Ram
    DirectX11
    Graphics Card GeForce GTX 765M
    Windows 8

    Thanks in Advance!


  • Mod

    would have to check whether the choppiness is computer performance or internet. If you can open the console in game and do ‘stat fps’ without the ’ it should show you your FPS. See how this fares while you’re playing.

    If the FPS is good, but things are still laggy, it might be something connection wise, like dropped packets. opening command prompt and pinging a server with something like ping -t 95.211.1.210 and let it run for a bit and see if any packets are lost

    Also it might be helpful to try running the game in safe mode (tick the safe mode box in the launcher) and try 64 or 32 bit versions (which ever you don’t use). Also if you could run through some of the common graphics settings - things like v-sync and let us know what you have setup it might be useful



  • @MonkeyFiend:

    would have to check whether the choppiness is computer performance or internet. If you can open the console in game and do ‘stat fps’ without the ’ it should show you your FPS. See how this fares while you’re playing.

    If the FPS is good, but things are still laggy, it might be something connection wise, like dropped packets. opening command prompt and pinging a server with something like ping -t 95.211.1.210 and let it run for a bit and see if any packets are lost

    Also it might be helpful to try running the game in safe mode (tick the safe mode box in the launcher) and try 64 or 32 bit versions (which ever you don’t use). Also if you could run through some of the common graphics settings - things like v-sync and let us know what you have setup it might be useful

    Alright first off thank you so much for responded. I checked the fps in game and it’s a lot lower than my desktop running the game. At some parts I’ll get 17 fps versus my desktop gets 60 fps… Please take note though that I never had a problem with the game on my laptop before one of the previous updates. When I updated a patch a few months ago it started right afterwards. I play many other games on here and never have a problem with any of them except one other game. I’m confused on what to do next now being that I believe I’m running a higher end rig and shouldn’t be having this problem.



  • Been waiting all day for another response. Please can anybody help me out with this? I’m starting to think it could be this game isn’t running because of the compatibility with windows 8…



  • No it is compatible with Win8, chiv just has issues. I have been tweaking all day. I have tested the nvidia settings, my mouse DPI and polling rates. So far what has started to minimize the stuttering is to turn on VSYNC with Triple buffering. Then try setting the render frames ahead to 2.

    I have a G500 mouse so I have lowered my polling rate to 250hz and raised my dpi to 1200. If you have those capabilities try variations.

    Also dont run Chiv in DX11. it should run in DX9 by default



  • I hate that triple buffering is not an option with AMD’s stock drivers / tools.



  • @Retsnom:

    No it is compatible with Win8, chiv just has issues. I have been tweaking all day. I have tested the nvidia settings, my mouse DPI and polling rates. So far what has started to minimize the stuttering is to turn on VSYNC with Triple buffering. Then try setting the render frames ahead to 2.

    I have a G500 mouse so I have lowered my polling rate to 250hz and raised my dpi to 1200. If you have those capabilities try variations.

    Also dont run Chiv in DX11. it should run in DX9 by default

    Alright I’ll try these today. Thanks for responding. :) Also I don’t need to do anything to run it in DX9 right? Because I know with win8 it automatically runs and updates DX11.



  • It should run Chivalry in DX9 by default. You can test this after you run Chivalry, ALT-TAB out of game and hit CRTL-ALT-Delete and open the task manager. Look at the processes and you should see Chivalry.exe(DX9) All windows versions will keep DX updated but it is the game that dictates what version it will use. You would have to add -dx11 to the command line of the game to get it to run in DX11.



  • I tried using RadeonPro to enable triple buffering but it doesn’t seem to hook properly. Also it makes the launcher crash.



  • Back to the ol’ vsync…



  • yeah I know there is supposed to be a way for AMD chips to do a version of triple buffer but I am not sure what it is or how to get it set up. You may have to look into it further.



  • Supposedly d3dOverrider (part of Rivatuner) can do it for AMD cards too, but it requires unsigned drivers and that’s too much bother.