Andrew asks we post our specs for Coldfront FPS issues



  • He also says to turn down Ragdoll slider, and asks that we tell him where we usually experience the most FPS drops on the map.

    I play with these settings.

    http://i.imgur.com/NQY03cI.jpg

    I usually get 45-60 FPS on most maps with 32- people, but with Coldfront it usually drops to around 20. It drops the most when looking across big open areas, especially towards the sun.



  • Stealth bragging topic

    Nice try IHOP.



  • What? My rig sucks, it’s a Mac Book Pro I got for free from school. I was just playing with Andrew and he asked that we post our specs in the forums and stuff. Sorry I didn’t take a screen.



  • Stealth Mac superiority topic.

    Nice try IHOP.



  • I like this seagull guy.



  • My fps drops pretty bad on the beach. I don’t get any noticeable fps drop on any other maps. I have an i5 and a 650 ti boost. I love Coldfront though I hope they can fix the fps drops.


  • Mod

    I’ve wrote my specs about five thousand seven hundred and ninety three point two seven times, but here we go again.

    i5 750 2.67GHz
    AMD 5850
    12GB DDR3
    Win 7 64 bit ultimate

    Game settings. On low setting I’ve noticed no noticeable framerate differences, I used to also use retsnom’s ini fixes. There’s no difference from what I’ve seen and nobody has been able to pin point anything that causes a significant increase in FPS…



  • http://pastebin.com/zj24JXtK
    All settings are set to low, resolution is set to 1920x1080, ragdoll length is set to 1 second.
    I haven’t found decreasing the resolution to have significant impact on the framerate.



  • @SOC:

    He also says to turn down Ragdoll slider, and asks that we tell him where we usually experience the most FPS drops on the map.

    It happens when you click the Play Chivalry button on the main menu. Go to control panel> remove programs> Chivarly
    this often gives partial peace until you reinstall it after the cold turkey dies a painful death of " I can always quit next time"
    biaatch



    • Win8

    • Intel Core i7-3770 CPU @ 3,40GHz (4 Cores 8 Threads)

    • 8GB RAM

    • NVIDIA GeForce GTX 660 (4GB)

    • 1920x1080

    • High Settings

    • Ragdoll length: 30 secs normally

    • Blood decals disabled

    • FoV: 135 atm

    No FPS problems.


  • Mod

    So does anyone with nvidia cards have these issues? Derp never mind :(



  • Pasting my post from another thread:

    Coldfront was not having any issues running on our min-spec on a full server. The only thing I can think of is it is some oddball system specific issue. A more useful thing (than removing it from the game entirely, would be for anyone having issues to post their specs and dxdiag in this thread. Noting problematic areas would help as well.

    Are you having issues after the initial beach invasion?

    SOC made a thread:
    http://forums.tornbanner.com/showthr…ont-FPS-issues

    Windows 7 Professional 32-bit
    Intel® Core™2 CPU 6600 @ 2.40GHz (2 CPUs), ~2.4GHz
    8800GTS
    4GB RAM (2GB usable)

    http://dumptext.com/2Sr9TqaV


  • Mod

    @Andrew:

    Pasting my post from another thread:

    Coldfront was not having any issues running on our min-spec on a full server. The only thing I can think of is it is some oddball system specific issue. A more useful thing (than removing it from the game entirely, would be for anyone having issues to post their specs and dxdiag in this thread. Noting problematic areas would help as well.

    Are you having issues after the initial beach invasion?

    SOC made a thread:
    http://forums.tornbanner.com/showthr…ont-FPS-issues

    Windows 7 Professional 32-bit
    Intel® Core™2 CPU 6600 @ 2.40GHz (2 CPUs), ~2.4GHz
    8800GTS
    4GB RAM (2GB usable)

    http://dumptext.com/2Sr9TqaV

    Does the game actually run with those specs? :O



  • @Tyoson:

    Does the game actually run with those specs? :O

    Low settings. Lower resolution (1280*960 I think)



  • I’ll post screencaps next time I encounter the map on a full(ish) server.
    Last time I was on a populated (30+ players) server playing Coldfront I was getting serious FPS drops on the beach area. Generally when looking towards the castle from Mason spawn or the beach area–staring at the ground caused my Game time to drop from 25+ ms to half that. It’s the only map/instance where my Game time is higher than my GPU time, which is pretty weird. Does anyone else notice this?

    Windows 7 Professional 64-bit
    Core i7 2600k (3.8Ghz stock; can OC it to 4.2+ if I still have problems maybe)
    Radeon 6950 2GB
    8GB RAM

    I’ve been messing with my graphics settings since then though. Didn’t have bloom/DoF enabled or vsync disabled before. Haven’t had much time to play the past few days.



  • That may not be it but…

    Andrew, did you use any brushes while building the walls/castle in Coldfront or just static meshes?

    On my map Valley I have been experiencing huge FPS loss, ONLY when using building brushes to make a bridge in the Editor. Later I replaced it with a static mesh and I instantly re-gained my FPS.



  • I believe it’s the PhysX. All Radeon users are pretty much screwed, this game will work worse on their machines and Coldfront is simply the map where it becomes the worst. Furthermore, my main rig is AMD CPU and AMD graphics card, and my laptop is Intel/NVidia combo where the overall parameters of the hardware are worse than on my stationary computer, but the game still runs better on the laptop.

    Why I think it’s PhysX? I saw some guy in chat complaining that he’s getting very bad FPS (about 30) on Coldfront and he said he has GTX780 Ti. I told him to go to NVidia Control Panel and switch PhysX from CPU to GPU. Once he did that, he automagically got a stable 60, and could probably pull off more if he disabled vsync and meddled with the .ini to unlock the framerate.

    I don’t know what the game uses PhysX for and why it cannot be disabled. If it’s gameplay relevant, people with AMD GPUs are pretty much screwed. If it’s gameplay irrelevant and is used only to produce eye candy then we should have option to disable it completely! I’m considering replacing my graphics card with NVidia just to fix FPS in Chivalry.

    I also noticed some FPS improvement when I lowered the fade out time of ragdolls, and I’d like to disable them completely but the death camera becomes all kind of screwed up when you do that and causes epillepsy inducing flashing. All other settings in the menu, except for ragdolls, are irrelevant when it comes to the FPS. I could set the lowest resolution with all lowest settings and there’d be no real difference between a moderate medium on 1920x1080. The thing that mostly affects my FPS is the amount of players on the server at the current moment.

    Just for the reference, my AMD computer:

    • AMD Phenom II X6 1055T @ 3.64 GHz
    • 8GB DDR3 RAM @ 1386 MHz
    • MSI Radeon HD 5850 Twin Frozr II 1GB RAM @ core:750 MHz, memory:1050MHz.
    • M4A78T-E mainboard.
    • Coldfront FPS: 30.


  • Internally, I have a force override on the npc ragdolls that will make them disappear after 5 seconds + some other optimizations that may help. No eta at the moment.

    Keep posting specs in the mean time. The more data the better.



  • AMD 7870
    8GB DDR3
    fx 8320

    everything low/turned off to get at least some stable fps which is really weird considering i can run bf 4 at high with this baked potato

    coldfront still unplayable (scrap archers pls)


  • Mod

    • Win 7

    • Intel Core i7-4770kCPU @ 4ghz-ish

    • 16gb RAM

    • NVIDIA GeForce GTX 680

    • 1920x1080

    • High Settings

    • Ragdoll length: 10

    • FoV: 120

    No FPS problems.