Re: Reworked parry/block system



  • 120 fps and 120 fov is the way to go for this game. at least for me anything below that feels uncomfortable



  • 120FPS isn’t possible because Unreal Engine 3.0 is capped @ 90FPS in Multiplayer sadly. In SP you can do unlimited, but in MP, 90 is max.

    I have a Nice 120HZ monitor myself, and you’re right, anything below 120FPS seems so…jerky and not smooth.



  • but fraps shows 120fps ingame. online.



  • The engine should not be capping your FPS regardless of local/networked play if you have bSmoothFrameRate set to True and MaxSmoothedFrameRate set to 120.



  • I set SmoothFrame Rate to false.

    And the 90 limit is part of the Engine in MP. Can’t get past this.

    Note: When playing online, the engine is capped at 90FPS regardless of these settings, and can’t be uncapped.

    Unless this has changed.

    And yes, Fraps shows you 120FPS, but anything over 90 is being dropped.

    Regardless, without SLI I can’t get over 90FPS at least then. Only one of my 670’s is being used.



  • I can get up to 120 fps in game using the ‘stat fps’ command with a single 570 on absolute max settings, so it’s definitely possible. If you set the max frame rate to 999 you will just get whatever the system can do, but it’s pointless aside from seeing the big numbers.



  • Very odd, and by max, what do you mean?

    I’m finding it hard to believe; there must be something wrong here, besides my resolution. I’m using MSI Afterburner and I see 50-60% CPU usage and 98% GPU usage.



  • Unless you have a 120 hertz monitor having more than 60 fps is only going to improve your input lag slightly.



  • Very odd, and by max, what do you mean?

    MaxSmoothedFrameRate



  • Not that. You said absolute max, in terms of graphics. I’m running with everything including SSAO @ 2560 x 1440p, which is over 50% more pixels than 1080p.

    And I have a 120HZ monitor man, so no worries there, I notice it alot in BF3 or other FPS’s. Day & night.

    In the tut, I’m only getting 60FPS or so…but it can go up to 90 at times. Wish this damn thing support SLI already.



  • I’ve split these posts off to another topic.

    Just highest settings @ 1920*1080. If you change the lines I mentioned earlier in Documents\My Games\Chivalry Medieval Warfare\UDKGame\Config\UDKEngine.ini, you will not be getting capped at 90 fps, I can say that for sure.

    As for SLI support, I’ll see what I can find out.



  • Hmm, even with the resolution change, your FPS @ max is rather high. If you’re saying you can maintain 120FPS at all times, that is.

    and yes, I changed that, but if I turn smooth on or off, doesn’t matter really, both achieve the same result.



  • Oh no, I’m not saying I maintain it, I just get it on some occasions such as in enclosed areas on the less resource hungry maps. It is dependent entirely on the map and where I am whether or not I can hit the 120 fps mark, some maps make it impossible to hit that for me, but the point I was trying to make is that it is possible and it’s not capped at 90 in networked games.



  • When you are able to get up to 120fps is that with all video settings set to High and True or Low and false?



  • most settings have to be low to maintain high fps, depends on your system though i guess.



  • what’s the point of fps capping?



  • fps capping was put in to limit rendered frames because it can put unneeded load on your system when your monitor or console cannot display that amount of them. UE3 is highly optimized for consoles sadly, so there is no AA, framerate is smoothed, and netcode isn’t very tight, etc.



  • I have been able to get over 90fps in multiplayer, I’m not sure exactly what setting got it there but the game seems to drop to the 40s and run like poop whenever I get it to work.

    I get my min and max both set to 125 I think and was able to get that much in certain spots in the maps, it doesn’t seem to make much effort to go above whatever you set as the minimum.

    Other Unreal Engine and UDK games have settings that disable the FPS Cap, in UT3 you just had to set yourself as LAN netspeed and you could go over 90 fps. I think the devs should do something about this and stop pretending like it’s not possible, we all spend good money on hardware and 120hz monitors and yet you can’t make the game work properly over 90?

    This game isn’t optimized very well, I have a Radeon 6970, 8GB Ram, Intel q9550 @ 3.8ghz, using about 35% of my GPU, about 40% of my CPU and struggles to maintain 60fps on some of the maps with high player counts while never maxing out any of my resources.



  • How do you get yours up to 90 in the first place? Mine never goes above 62 regardless of whether vsync is enabled or not or if I have all details set to minimum.



  • i have posted it a while ago in the support section

    viewtopic.php?f=69&t=4809

    works fine for me with this i have 120 fps all the time


Log in to reply