No servers



  • Okay, so I played the game on the free weekend and no server showed up so I just played with BOT’s and enjoyed it so I decided to buy the game today and after I bought it I thought the servers would show but they still didn’t. I’ve been looking at all different solutions and none have worked, I am not opted into anything. Can someone please help me with this? Thanks.



  • Try this solution:

    1. An anti-virus program is running and blocking required internet traffic from our game to Steam. Ensure that Chivalry is given full permissions through your anti-virus program.

    2. It is possible Steam is having issues, restart Steam and try again.

    3. Your router NAT table is being overloaded. You can lower the maximum allowable pings in order to see more servers.
      How to allow for higher pings in Steam.

      1. Run the Steam client.
      2. Navigate to the Steam menu at the top of the window.
      3. Select Settings.
      4. Navigate to the In-Game tab.
      5. Under the heading “In-Game server browser: Max pings / minute” select “Automatic (1500)”


  • @DaGGyzo:

    Try this solution:

    1. An anti-virus program is running and blocking required internet traffic from our game to Steam. Ensure that Chivalry is given full permissions through your anti-virus program.

    2. It is possible Steam is having issues, restart Steam and try again.

    3. Your router NAT table is being overloaded. You can lower the maximum allowable pings in order to see more servers.
      How to allow for higher pings in Steam.

      1. Run the Steam client.
      2. Navigate to the Steam menu at the top of the window.
      3. Select Settings.
      4. Navigate to the In-Game tab.
      5. Under the heading “In-Game server browser: Max pings / minute” select “Automatic (1500)”

    Tried all of those but nothing worked, thanks anyway.



  • I have tried absolutely every solution I could find that worked for others, I might just have to see if steam will give me a refund.



  • You’re certain that you are running the full game and not the BETA version?



  • I’m positive, at one point I did try it in the BETA version to see if anything would change but nothing happened so then I just wen’t back to the normal version.



  • I’m having the same problem. I’ve tried everything that I can think of. Uninstalled and reinstalled even.



  • Yeah, I’ve tried that too, multiple times. I must of uninstalled and resinstalled the game about 3 times now!