Chivalry: Deadliest Warrior - Connection with host timed out



  • Dear support/forum,

    Whenever I play on a server, no matter what gamemode, ping or population I get “Connection Timed out with host” after playing only 5 mins.

    I’m not sure if this is a bug or a well known issue, but is there annyway to fix that?
    I got a stable internet connection and I am connected with a wire (not wireless).

    I also checked my firewall

    Any help is appreciated!

    Best regards,
    MazZ

    Screenshot:

    My computer specs are the following:

    • CPU: AMD phenom x6 1100T
    • GPU: ATI 280x 3GB Vram
    • RAM: 8Gb DDr3 ram (Dominator)
    • MOB: ASUS M5a-88m
    • OS: Windows 7 64bit
    • Internet connection:


  • Sorry but bump, this makes playing online unplayable.

    • I have checked firewal, steam setting, verified integrety of game cache, nothing seems to work.


  • This seems very much like a network issue. Have you checked your router settings?



  • Yes checked firewalls on both router and windows, I’m also pretty sure it’s not my internet connection cause I can play other games online just fine.

    but even if it was my firewall, shouldn’t i get this time out directly instead of after 5-10mins?

    @DaGGyzo:

    This seems very much like a network issue. Have you checked your router settings?



  • Try this solution:

    How to allow for higher pings in Steam.

    1. Run the Steam client.
    2. Navigate to the Steam menu at the top of the window.
    3. Select Settings.
    4. Navigate to the In-Game tab.
    5. Under the heading “In-Game server browser: Max pings / minute” select “Automatic (1500)”


  • I’m affraid I allready tried that :(

    @DaGGyzo:

    Try this solution:

    How to allow for higher pings in Steam.

    1. Run the Steam client.
    2. Navigate to the Steam menu at the top of the window.
    3. Select Settings.
    4. Navigate to the In-Game tab.
    5. Under the heading “In-Game server browser: Max pings / minute” select “Automatic (1500)”


  • Finally found what it was, the servers I played on kept crashing. I now found a stable server and ive been able to play for hours :)

    Thanks for your support annyway DaGGyzo :)
    @MazZ:

    I’m affraid I allready tried that :(