Ligthing Problem. Strange shadows on rocks after building light



  • Hallo,

    does anyone know what happens to my rocks after building light?
    They have strange shadows. If i move my “sun”, they will look normal again. But after building light… crap :(



  • Do you get any lighting warnings when building?



  • Yes several “Object has overlapping UVs” errors.



  • What are these object ? If they are not the rock in your picture, I think it’s a matter of lighting setting.

    It’s hard to tell you how to set the shadows and lights but you can try to add a new rock (from the Content Browser) and compare the setting with the ones you have in the map.

    It may also be a setting in the “world properties” too (lightmass…).

    The best you can do is open a map from TBS and copy past the setting. After that, you ll be able to see what you need to have good lighting.



  • Using same world properties as eg stoneshill doesnt work.
    These are static meshes. Well if i choose a different rock from the content browser, i have no darkness. I think i will replace all broken rocks… meh



  • Looks like an error in the material setup of the object rather than lighting. Dunno how you’d fix it but it’s a place to start.

    What’s the name of the meshes causing the problem?



  • Ok i got it.
    I compared the settings of the working rock with the dark one. In static mesh editor i changed “light map resolution” to 64 and “light map coordinate index” to 1. But i cant save the changes because of “cooked content” hmm

    The name is Rock_02.

    Is there a way to export this mesh and import to my own package?



  • you can override the lightmap resolution in the object’s properties (F4)



  • @zombojoe:

    you can override the lightmap resolution in the object’s properties (F4)

    I tried but no success. I have replaced every rock now. yay