Cooked map issues

  • Hey guys, I ran into a very frustrating problem…

    My map doesn’t work when uploaded to the workshop.

    In the offline/editor version of the map, everything works fine. The map has a few flying dragons I extracted from Skyrim and they fly around using matinees in kismet. Their models, textures and animations are all extracted from a package that comes with the map. (.upk)

    When I put this map online on a server however, one of 2 things happen.
    1)The server times out upon mapchange to my own map and I get kicked with the usual “No connection” message.
    2)The server goes back to it’s first map in the map rotation and shows me this error:

    It’s really frustrating. What seems to fix it, partially, is to set the dragon animation matinee’s to Client-side.
    The map still works in single-player and in the editor. However, now the problem is:
    None of the dragons actually execute the matinee and remain in their T-pose for the entire map. Their start event is as soon as the map loads/resets, but it doesn’t seem to work on the client side version.

    So I can choose between having a map that doesn’t even load or a map that breaks the few things that made me spend over 2 days to actually get into the map.

    What could be causing the error? Is it because I’m using a package with custom assets? It’s weird, because the models and textures work fine. The animations are probably fine as well, but the map just doesn’t execute them.

    Phew, long post. I hope some of you on this forum can immediately point me to what I did wrong, because I’m completely clueless.

  • Even when converting it all to client-side, which is hardly a solution, I keep getting this error now too. Whatever I do, the error occurs when loading the map on the server.

    I also already tried:
    *Uploading the map to the workshop, categorized as a map that requires a mod to run(the mod being Sky.upk). Oddly enough there was no major difference, just the same error.

    *Opening the package sky.upk that gets exported and re-downloaded from the cooked map when subscribed to the workshop item. It’s the exact same package; the animations that fail to play are all still in there.

    So to summarize: The dedicated server can’t play the newly added animsets, forcing an “Invalid SDK Map”-error and as such rendering the map unplayable in multiplayer.

    Anyone with an idea for what to do now? Because I’m still quite clueless.

  • It sounds suspiciously like a workshop type error. Have you only got 1 workshop item with thus in?
    Check the package name us uniquie … maybe sky.upk change to something longer?

    Just an idea but i would rule this out first

  • I already followed these steps manually Otreum. But thanks for all the suggestions thus far.

    Honestly, I figured out the problem just now and am quite ashamed to say it. You guys probably couldn’t have figured this out without more information, and I should have checked earlier before renaming packages and changing links and stuff.

    Problem = Workshop item was set to “Hidden”.
    Not even kidding. I assumed that option was only for the actual workshop page, not the content itself. But it worked after setting it to “Public”.

    Now I understand why KyWild’s exp mod was just a descriptionless workshop item without image, instead of just a hidden item.

    Still though, thanks guys. It’s great to have some very experienced users on this forum that aren’t all harassing other posters in discussion boards :)

  • ah - that’s why my latest secret test kicked up an error on a map change - thanks!!!

Log in to reply