Ram Isn't Damaging Gate

  • So I’ve got the ram on my map all setup with a correct Matinee scene and objective which completes correctly once the ram reaches the gate. But using the ram does not damage the gate, which is set up correctly I believe, it has the physics asset and anim trees set and the damage taken kismet nodes setup. I’m just a little confused about what is not working or missing.

    My kismet is almost exactly to the example maps, Pushable /Basic Setup/ Destruction via looking at it through editor and the Wiki. I am at a loss what else to try, as I’ve tried tweaking kismet, and moving the ram closer to no affect.

  • So… going to bump this because time is getting kind of short… and I’d like to have this working, if anyone has any troubleshooting tips. I’m at a loss and about to scratch the gate objective from the map.

    Secondly, I’ve done some new shaders/materials for the map which have come out looking great, but the shader compiler is acting like it’s been corrupted. I’ve done a verify cache on Chivalry through steam to make sure it’s not borked, but it seems that doesn’t really fix anything. I don’t think my new shader is too big or anything, it’s actually very efficient as far as memory should be concerned. The SDK and Frontend seem to be crashing/freezing up to a point where I can’t even use task manager to close them. Which is really strange…

  • hm
    Maybe too much health?
    Does the gate have collision “block all”?
    Maybe wrong damage typ in take damage settings?
    Does the gate break if you change the damage typ?
    Is the gate a static mesh actor?
    many options^^

    You could also open the official maps or other sdk maps and have a look.

    If nothing does work, make a interpactor gate and destroy it (“destroy actor” in kismet) when your ram has arrived.

    good luck

Log in to reply

Looks like your connection to Torn Banner Forums was lost, please wait while we try to reconnect.