Can't play my map after Cooking it.



  • I got a problem with my map…After cooking it. Everything works fine when I play it in the editor. adding bots and playing through the objectives till the end.

    But when I start my map after cooking it with console command, the game doesn’t start up properly. I get to be a camera ( not even a spectator (can’t fly)) I do not get the choice of choosing team as I do when playing in the editor. I can’t add bots nor use the escape button only console commands… like quit :)

    I’ve tried removing all spawns that I had placed in the map. And just add one EFAC_Agatha, EFAC_Mason, EFAC_None but still get the same result after rebuilding and recooking. So I guess the problem doesn’t lay in the spawns… There is something else ?

    I can’t seem to figure this out. Any ideas ?



  • Rebuild your AI navigation.



  • What exactly do you mean by that? I guess that I rebuild the AI navigation when i do a Build All ?. I also added Polyns. Still the same result. Thanks for answering.



  • Check in World properties if your gamemode is set up correctly - Team objective. You are propably only using team objective for PIE mode.



  • @Vesanus:

    Check in World properties if your gamemode is set up correctly - Team objective. You are propably only using team objective for PIE mode.

    I do have that set up, both for PIE and Default Game Type.



  • @cribbel:

    I do have that set up, both for PIE and Default Game Type.

    You need to select all of your path nodes and rebuild the pathing for them (right click build pathing with them selected) and it’ll just build the pathing for those. It’s a simple fix.



  • @Nexussfire:

    You need to select all of your path nodes and rebuild the pathing for them (right click build pathing with them selected) and it’ll just build the pathing for those. It’s a simple fix.

    This dosen’t do it.



  • It’s a weird problem.
    I tested - AI Pathing - Spawns - gametype and it has nothing to do with kismet… Its so strange, because everything worked out in the editor. I went back to earlier stages of the level… and the problem exists there to…To bad that i did not notice it back then… And if i cook one of the example maps it works… So it’s so weird… What have i done to this map.



  • Make sure that the spawn points ARE actually enabled and not being disabled. Also make sure your gametype in your world settings are correct. I had a similar issue when I first started in the competition, so stripped my spawn points and did it exactly how it’s done in the example maps, and it worked…obviously I did something wrong :P



  • Yes, i tried most things with the spawns… It was my first thought aswell. I even copied over the spawn points that’s used in the example maps. And also went back to older versions of my map, to add them…



  • I just made a new map from scrach… one bsp one light 3 AOCPlayer starts… Gametype set… cook it… Same result ?