Issue building to workshop.

  • Just tried to cook and upload my final build before I head out of town tomorrow and ran into a runtime error;

    Warning, Forcing UseTextureFileCache to FALSE for CookedPC…
    Success - 0 error(s), 1 warning(s)
    Execution of commandlet took: 51.37 seconds
    [Jun 27, 1:11 PM] COMMANDLET ‘UDKEditor.exe CookPackages -nohomedir -platform=PC AOCTO-Cove_beta_p.udk -Guid=a41c3fc749eeeb28310cf8866d45c7f3 -final_release -multilanguagecook=INT -ModName=aocsdklevels’ SUCCEEDED
    [Uploading to Steam] Jun 27, 1:11 PM
    [COMMANDLET ‘WorkshopUserTool.exe wsinfo_aocsdklevels.txt’ STARTED IN ‘C:\Games\Steam\steamapps\common\chivalrymedievalwarfare\Binaries\Win32’] Jun 27, 1:11 PM
    Looking for $MapContest
    Found $MapContest
    WSTOOL: Initializing Steam client
    Waiting for Steam task to finish.
    WSTOOL: Getting file details for user Workshop FileId: 238299932
    –—> Successfully got file details for FileId: 238299932, Filename: “aocsdklevels_a41c3fc749eeeb28310cf8866d45c7f3.cmwsdk” Published: 1, Subscribed: 0
    WSTOOL: Adding file(s) from directory: “…\UDKGame\CookedSDK\aocsdklevels_a41c3fc749eeeb28310cf8866d45c7f3” to archive: “C:\Games\Steam\steamapps\common\chivalrymedievalwarfare\UDKGame\CookedSDK__CMWSDKFiles\aocsdklevels_a41c3fc749eeeb28310cf8866d45c7f3.cmwsdk”
    -----> Adding file: “UDKGame\CookedSDK\aocsdklevels_a41c3fc749eeeb28310cf8866d45c7f3\AOCTO-Cove_alpha_p.udk”
    -----> Adding file: “UDKGame\CookedSDK\aocsdklevels_a41c3fc749eeeb28310cf8866d45c7f3\AOCTO-Cove_beta_p.udk”
    -----> Adding file: “UDKGame\CookedSDK\aocsdklevels_a41c3fc749eeeb28310cf8866d45c7f3\AOCTO-Cove_prealpha_p.udk”
    -----> Adding file: “UDKGame\CookedSDK\aocsdklevels_a41c3fc749eeeb28310cf8866d45c7f3\Civ-Cove.upk”
    -----> Adding file: “UDKGame\CookedSDK\aocsdklevels_a41c3fc749eeeb28310cf8866d45c7f3\Cove\AOCFFA-Cove_beta_p.udk”
    -----> Adding file: “UDKGame\CookedSDK\aocsdklevels_a41c3fc749eeeb28310cf8866d45c7f3\Cove\AOCLTS-Cove_beta_p.udk”
    -----> Adding file: “UDKGame\CookedSDK\aocsdklevels_a41c3fc749eeeb28310cf8866d45c7f3\Cove\AOCTD-Cove_beta_p.udk”
    -----> Added 7 file(s) to archive “aocsdklevels_a41c3fc749eeeb28310cf8866d45c7f3.cmwsdk”
    -----> Adding file: “UDKGame\CookedSDK\aocsdklevels_a41c3fc749eeeb28310cf8866d45c7f3\SDKShaderCache-PC-D3D-SM3.upk”
    -----> Adding file: “UDKGame\CookedSDK\aocsdklevels_a41c3fc749eeeb28310cf8866d45c7f3\SDKShaderCache-PC-D3D-SM5.upk”
    -----> Added 9 file(s) to archive “aocsdklevels_a41c3fc749eeeb28310cf8866d45c7f3.cmwsdk”
    WSTOOL: Compressing archive: “aocsdklevels_a41c3fc749eeeb28310cf8866d45c7f3.cmwsdk”
    [Jun 27, 1:12 PM] COMMANDLET ‘WorkshopUserTool.exe wsinfo_aocsdklevels.txt’ FAILED



  • Just tried uploading as a new workshop Item, it seems to be working fine. Workshop my be having a fit, anyone else had this issue?

  • I think I may have solved it be removing my map directory (Steam GUID one) from the Cooked SDK folder.

    That seems to have worked. Update was pushed to workshop and seems to be all ok.

  • Yeah mate, that error once occurred for me and I did exactly what you did to fix it. Glad it’s A-OK now! :D

Log in to reply