Unable to tab back into the game



  • More often than not when I tab out of the game I’m unable to tab back in afterwards. It makes no difference whether I click the icon or alt-tab. It’s very frustrating because it always requires me to close via task manager. The problem there is that it completely locks up my task manager and literally takes closer to 5 minutes just to close CMW.exe. On occasion it’s caused windows explorer to crash as well.

    I’ve tried playing without any additional applications running such as internet browsers, VoIP software, anti virus, peripheral software (logitech gaming software & razer synapse), AMD’s Raptr, etc. It’ll still lock up the same way. I’ve tried completely uninstalling then reinstalling latest GPU drivers, and all other drivers are up to date. I’ve tried reinstalling as well. I’m not sure how common the problem is but I know at least one other person this happens to regularly. I’ve been unable to find relevant similarities between our setups to try and pinpoint the problem.

    To be honest It makes me think twice about playing sometimes because I know I’ll need to alt-tab to at least do things like change music, and honestly with a SSD it ends up being faster to just restart. It wouldn’t be so bad if it didn’t happen 60% of the time. I’ll attach a DxDiag in case anyone can look into it. The issue began happening when the patch that changed the loading screens, browser, and 64-bit capability was released a few months ago.



  • Happens to me a lot, particularly when alt-tabbing while a map is loading. I have no knowledge of coding but I feel like it’s connected to how you can’t skip the intro movies, they have weird priority or loading settings or something and you can’t even alt-tab out during them. No other game I play does this with load screens either, it’s a simple tab-out, tab back in and if it’s still loading it’ll show the load page.



  • I think it’s a known issue on some systems running 64 bit chiv, try forcing 32 bit and see if it still happens.

    also try:

    right click the game in your library
    click ‘properties’
    type:
    -borderless -resx=[your X-res] -resy=[your Y-res]

    so for example:

    -borderless -resx=1920 -resy=1080



  • Forcing 32-bit didn’t help at all. But ah, borderless…This is essentially the solution I was after but I didn’t think it was an option In Medieval Warfare like in Deadliest Warrior since it’s not a part of the video options. I have no problem at all alt-tabbing in borderless :D

    Thank you for your help MonkeyFiend!



  • I tried doing that but I get a weird stutter every 10 or so secs so I had to revert it :/ I guess I’ll have to wait for a fix from the devs if they know/can figure out why it does this



  • I may have spoke to soon, the tab issue is fixed but I can a consistent crash 5-15 minutes after launching the game. Even with the original issue I would rarely get regular crashes, only the few times when I see my entire friends list empty and I assume it was a global thing.


Log in to reply