Can´t find server in serverlist



  • Hi together!

    I have a tiny little, problem with my dedicated server.
    I host it on a VirtualBox ob a dedicated server in a DC in Frakfurt/Germany.

    Hostsystem is Debian.
    It is a Win8.1 VM, i forwarded all ports (7777, 7778, 27015) by VirtualBox and can connect via Game-Console (open ipaddress:port)
    A friend can join too but the Server does not show on the server-list in game.

    Now the question is: Is it a problem from VirtualBox? A portscanner find all open ports!
    I use NAT because i have only 1 IP for the dedi-server.

    My next option is to order a 2nd IP an try it with the bridging-mode in Virtualbox.

    Here is the Log from the start:

    [0006.75] Init: Version: 10246[0006.75] Init: Epic Internal: 0
    [0006.75] Init: Compiled (32-bit): May 27 2014 10:20:21
    [0006.75] Init: Command line: AOCTO-Hillside_P?dedicated=true?steamsockets -seekfreeloadingserver
    [0006.75] Init: Base directory: C:\steamcmd\chiv\Binaries\Win32
    [0006.75] Init: Character set: Unicode
    [0006.75] Log: Executing Class Engine.ServerCommandlet
    [0006.75] Log: Initializing Game Engine…
    [0006.78] Init: UEngine initialized
    [0006.80] Log: Steam Client API is unavailable (not required for servers)
    [0006.83] Log: Read config file: …\UDKGame\Config\UDKUI.ini
    [0006.83] Log: Read config file: …\UDKGame\Config\WrangleContent.ini
    [0006.97] DevDlc: Initialize Called
    [0006.97] Warning: Warning, Failed to load ‘Class None.’: Failed to find object ‘Class None.’
    [0006.97] Warning: Warning, Failed to find object ‘Class None.’
    [0006.97] Warning: Warning, Failed to load ‘Class None.’: Failed to find object ‘Class None.’
    [0006.97] Warning: Warning, Failed to find object ‘Class None.’
    [0006.97] Log: Read config file: …\UDKGame\Cloud\CloudStorage.ini
    [0006.97] DevDlc: DownloadableContentManager NewState DS_GetFileDetails
    [0006.97] DevDlc: Waiting for Workshop download…
    [0006.97] DevDlc: Shipping Level: EnvyEntry
    [0006.98] Log: LoadMap: EnvyEntry?Name=Player?Team=255?dedicated=true?steamsockets
    [0006.99] DevDlc: Shipping Level: EnvyEntry
    [0007.00] Log: Game class is ‘UTEntryGame’
    [0007.00] Init: WinSock: Socket queue 131072 / 131072
    [0007.01] Init: WinSock: I am Hel (10.0.2.15:0)
    [0007.01] Init: WinSock: Socket queue 131072 / 131072
    [0007.01] Log: Initialized RedirectNetDriver, for redirecting IP connections to Steam sockets
    [0007.06] Log: NetMode is now 1
    [0007.07] Log: Primary PhysX scene will be in software.
    [0007.07] Log: Creating Primary PhysX Scene.
    [0007.08] Log: Bringing World envyentry.TheWorld up for play (60) at 2014.07.16-12.54.12
    [0007.08] Log: Bringing up level for play took: 0.018869
    [0007.08] Log: ########### Finished loading level: 0.102146 seconds
    [0007.08] Init: Game engine initialized
    [0007.08] Log: Initializing Game Engine Completed
    [0007.11] DevDlc: DownloadableContentManager NewState DS_DownloadFiles
    [0007.12] DevDlc: DownloadableContentManager ResetConnection
    [0007.12] DevDlc: DownloadableContentManager NewState DS_Inactive
    [0007.12] DevDlc: Looking for DLC…
    [0007.12] DevDlc: Shipping Level: AOCTO-Hillside_P
    [0011.11] Log: Server switch level: AOCTO-Hillside_P
    [0011.11] DevDlc: Shipping Level: AOCTO-Hillside_P
    [0011.12] Log: LoadMap: AOCTO-Hillside_P?Name=Player?Team=255?dedicated=true?steamsockets
    [0011.15] Exit: IpNetDriverSteamworks_0 shut down
    [0011.15] Log: FSocketWin::Close
    [0011.15] Log: FSocketWin::Close
    [0011.15] Exit: IpNetDriverSteamworks_1 shut down
    [0011.16] DevDlc: Shipping Level: AOCTO-Hillside_P
    [0011.38] Log: Read config file: …\UDKGame\Localization\INT\aocto-hillside_p.INT
    [0011.39] Log: Game class is ‘AOCTeamObjective’
    [0011.40] Init: WinSock: Socket queue 131072 / 131072
    [0011.40] Init: WinSock: Socket queue 131072 / 131072
    [0011.40] Log: Initialized RedirectNetDriver, for redirecting IP connections to Steam sockets
    [0011.44] Log: NetMode is now 1
    [0011.46] Log: Primary PhysX scene will be in software.
    [0011.46] Log: Creating Primary PhysX Scene.
    [0011.46] Log: Bringing World aocto-hillside_p.TheWorld up for play (60) at 2014.07.16-12.54.16
    [0011.50] Log: Initializing Steam game server
    [0011.53] DevDlc: Shipping Level: aocto-hillside_p
    [0011.54] DevDlc: Shipping Level: aocto-hillside_p
    [0011.57] DevDlc: Shipping Level: AOCTO-Hillside_P
    [0011.57] DevDlc: Shipping Level: AOCTO-Hillside_P
    [0011.57] DevDlc: Shipping Level: AOCTO-Battlegrounds_v3_P
    [0011.57] DevDlc: Shipping Level: AOCTO-Battlegrounds_v3_P
    [0011.57] DevDlc: Shipping Level: AOCTO-Darkforest_p
    [0011.58] DevDlc: Shipping Level: AOCTO-Darkforest_p
    [0011.58] DevDlc: Shipping Level: AOCTO-Stoneshill_P
    [0011.58] DevDlc: Shipping Level: AOCTO-Stoneshill_P
    [0011.59] DevDlc: Shipping Level: aocto-hillside_p
    [0011.60] DevDlc: Shipping Level: aocto-hillside_p
    [0011.64] DevDlc: Shipping Level: aocto-hillside_p
    [0011.65] Log: Bringing up level for play took: 0.204718
    [0011.65] Log: ########### Finished loading level: 0.533050 seconds
    [0011.67] Log: Flushing async loaders.
    [0011.94] Log: Read config file: …\UDKGame\Localization\INT\aocto-hillside_game.INT
    [0012.57] Log: Flushed async loaders.
    [0013.68] DevDlc: Shipping Level: aocto-hillside_p
    [0013.70] Log: Steam game server UID: 90091209475726341
    [33630.16] NetComeGo: Open TheWorld 07/16/14 22:14:35 xx.232.110.222
    [33630.43] NetComeGo: Close IpNetDriverSteamworks_3 IpNetConnectionSteamworks_0 xx.232.110.222:50718 07/16/14 22:14:35
    [33630.48] NetComeGo: Open TheWorld 07/16/14 22:14:35 xx.232.110.222
    [33849.46] NetComeGo: Close IpNetDriverSteamworks_3 IpNetConnectionSteamworks_1 xx.232.110.222:50718 07/16/14 22:18:14
    [37351.77] NetComeGo: Open TheWorld 07/16/14 23:16:37 xx.24.151.136
    [37352.03] NetComeGo: Close IpNetDriverSteamworks_3 IpNetConnectionSteamworks_2 xx.24.151.136:5050 07/16/14 23:16:37
    [37352.08] NetComeGo: Open TheWorld 07/16/14 23:16:37 xx.24.151.136
    [37356.35] NetComeGo: Open TheWorld 07/16/14 23:16:41 0.0.132.108
    [37368.79] DevSteam: ReadUserStats(76561197960299628) completed with result ‘1’ k_EResultOK (success) and took 459ms

    Thank you guys! For your help.



  • If you can join then it is a problem with the QueryPort.

    Can you see if it is using the 27015 port?
    Use “netstat -tulpn” to see what process is using 27015.



  • Hi,

    Port 270015 is open.
    Question: 27015 UDP or TCP? Anyway, i have set both now.



  • It works! Thank u!

    Important: Queryport for Steam: 27015 UDP! :D



  • You’re welcome! Glad to hear you got it going.


Log in to reply