Failed to create D3D9 Device.



  • After installing the game via steam, doing the same thing for every other game I’ve installed. I started it up. A black screen pops up with the right side cut out where you can see the back ground programs i.e. Chrome/Steam/ what ever is up at the moment.

    A window pops up saying “Failed to create D3D9 device! This can happen because the desk top is locked. Exiting”

    I don’t think it’s the desk top being locked, since it’s not. I did some research in to it and found a post regarding the same problem but for Black Light Retribution. There it said you have to change the resolution of the game by going threw the folders manually. ( http://blacklight-forum.perfectworld.co … p?t=220651 )

    Since the black screen wasn’t covering the entire screen I assume that is the problem. Though I don’t want to jump to conclusions. I also feel I should post this for other people who may have the same problems.

    I’m not all sure where the folders would be, I’ve messed around with doing stuff like this before in Arma but never with a Steam game. I don’t even know where Steam games can be found.

    Could someone help me find the place where I can change the resolution of the game. Thanks



  • You can change the resolution by going to
    My Documents\My Games\Chivalry Medieval Warfare\UDKGame\Config\UDKSystemSettings.ini,

    alternatively, you can run the game with the -windowed options in the launch options on Steam.



  • Thanks, That helped =D



  • Erm, i cant find the resolution in the ini file. I can only find secondary resolution



  • ResX and ResY are the resolution numbers.



  • Still no fix :/ I backdated the drivers before then updated to the beta drivers, what should i do :/



  • Set -windowed mode.
    Or in the ini file set bFullscreen to false



  • Ah, worked xD i did it in the steam instead of my games. Great support btw



  • No problem! Tell your friends :)


Log in to reply