Black material



  • I feel like this is one of these moments where I’m just being a complete idiot and did something stupid, so I’ll be short about this one.

    A skeletal mesh actor is using it’s custom material just fine in the editor, but in-game the material turns pitch black when the player comes close.
    This also only seems to happen when I have my in-game Texture Quality setting set to Medium, Medium-High or High. It works fine (but looks ugly, obviously) when I set it to Low or Low-Medium.

    Issue:
    https://www.youtube.com/watch?v=cD8V_K3-f94

    This is the material:

    (Once again, it works just fine in the editor. But I guess that’s the case with 99% of the custom map problems.)



  • What format is the texture in?



  • @Nexussfire:

    What format is the texture in?

    It’s all in .png format.
    1024x2048.



  • You might try using 24bit TGA instead, the Normal as well.



  • @Nexussfire:

    You might try using 24bit TGA instead, the Normal as well.

    Seems to make no difference.

    This problem is confusing me greatly, why on earth does it only happen on decent settings?



  • Okay. Do you have LOD’s setup for this model? Might also be the problem. Or it’s just a dynamic light problem, to which case you might consider rebuilding lighting with a lightmass volume.

    If that doesn’t fix it, it’s down to the model itself having faces pointed in the wrong direction, or something else. Since it’s a skeletal mesh, the light environment can be really glitchy/weird. You’ll need to setup a physics asset for it, if you haven’t already, and then tinker around with some of the light settings for the mesh itself. The physics asset will help the model cast it’s own shadows. And it’s just down to figuring out what light settings work.

    You might want to look at some of TB’s physic’s assets to get an idea about what settings work best for those. And maybe look at one of the skeletal mesh actors and see how it’s setup as well, Light channels and such.



  • I had similar problem before. This doesn’t seem to be exclusive to Chivalry SDK as I had the same issue with other UDK-based games. Anyway, the solution is to set the texture’s LOD Group to something different. If the package is cooked with the default LODGroup seen in the import window, then for some reason in-game the texture will appear black and only distant, mipmapped texture is visible. Remember to do this for both, diffuse and normal map.



  • I got it fixed. Not sure what part fixed it, I tried everything simultaniously what both Nexussfire and Ferum suggested.

    Thank you so, so much for your help. Truly appreciated, I’ve been clueless for quite some time as to why this didn’t immediately work.
    Also shame on UDK for making something that should be so easy, so unnecessarily hard.



  • Yeah, I’m not sure why the Skeletal mesh handling isn’t as streamlined as the rest of the tools. I’ve heard it’s way better in UE4.

    Glad you got it all sorted out.



  • Glad you got it sorted out! It’s worth noting that this issue might appear not only on skeletal meshes but static as well.



  • I was going to suggest changing the “Whole scene dynamic shadow radius”, but it didn’t seem like it would be the problem.



  • This dragon seems impressive ! Show the people it was not a legend ;)
    I wish you all the best.


Log in to reply