Trouble with game launching (editor)



  • Hello !

    We’re working on a TO map but we have a problem. Since today, when I want to launch the game in the editor, the game is not lauching. I add one bot with “addbots 1” command, but not working. I add 5 bots with “addbots 5” and it works ! But why ?

    I upload the map on the Workshop, and I test it on my server with a friend, but the game is still not launching. I have to add some bots to make it work.

    I don’t understand… Help me please.

    Thank you, bye.



  • I don’t really understand what you are saying…?

    A Team objective map starts when there is one players on each side (Mason & Agatha).

    When you mean "launching the game - do you mean that you can’t get spawned? Or do you simply mean that objective doesn’t start unless you add bots (which is preposterous)?

    Maybe check your kismet if you didn’t mess something up. You can check other maps’s kismet setting to make sure if everything is alright. Also check world properties if the mode is set to Team objective (not AOCentry).



  • Yeah it’s hard to explain.

    I mean… When I “launch the game”, I spawn. Of course I need to add 1 bot to launch the game, but it doesn’t work… So i tried to add more than 1 bot, 5 for example and it works. So, if we are 2 on the server, 1 on each side, we spawn but the game doesn’t start, we need to be 5…

    I checked the kismet and I found no problem, and Game Type is set to Team Objective and not AOCentry :/



  • Ok I found the problem !

    I deleted a big part of my kismet, and it worked. So I searched where the problem was and it was some PathNode who were placed under the Landscape. I don’t understand the logic of the bug, but we don’t care ^^

    Thank you !



  • Umm. Good to hear that everything is now working properly ;)

    Good luck with Chiv SDK!



  • Yeah this kind of thing is normally a path nav mesh type issue.

    Checjball path nodes on same level
    Check all are viable
    Make sure paths are rebuilt.



  • Ah, and so you venture into the Rabbit hole that is UDK, good luck Wardruna, you are going to need that, and plenty of patience :P

    Glad to hear you resolved the issue :)


Log in to reply