Custom map disappearing from rotation (WTF!)



  • So, I have this erratic and baffling issue on my dedicated Free Duels server and I was hoping you could maybe help me.

    The server is running fine, with all the proper maps listed in the rotation as well as in the sdk map list. Then I may login a few hours later and I notice the server is rotating with only one map instead of 2. This map also disappears from said rotation, and also disappears from the list of SDK maps.

    I’ve tried setting bDontAddSdkMapsToList to both true and false, and neither really fixes the problem.

    This is what my startup line looks like:

    [b]AOCFFA-DuelYard_p ?steamsockets?maxplayers=12 -configsubdir=DuelzFFAO -sdkfileid=200205982 -sdkfileid=298849843 -sdkfileid=192990126 (plus other params)[/b]
    

    The Configsubdir DuelzFFAO has a copy of the PCServer-UDKEngine.ini and PCServer-UDKGame.ini. The rotation (Maplist, on UDKGame…) has only 2 maps:

    Maplist=AOCFFA-DuelYard_p
    Maplist=AOCFFA-Evergreen_p
    

    The third map is not included in the rotation, but I set the server to download it in case players request it.

    When the rotation breaks, one of the 2 duel maps is always gone. I enter getserverrotation and there’s only one. I type in getserversdkmaps and there’s a few maps, but of the 2 duel maps. which due to being included in the startup line should be forced to be available, one of them is randomly gone.
    The only way to fix it is to restart the server, until this happens again.

    I tried leaving only 2 sdkfileids in the startup parameters. I tried switching around which startup map loads (instead of Duelyard I’d put Evergreen, and invert the maplist). In any event, the issue randomly occurs under both settings.

    What the hell? Please notice that the server can run for full days, so it’s not like I’m restarting it with wrong startup parameters.
    I don’t know what else to try.


  • Mod

    well that’s a new one for me :P

    I assume when the map disappears you can still adminchange to it?
    Have you got any mods loading like blackknight or lazermod etc.?
    What’s in your serverdownloadlist?

    Failing the obvious might be worth trying to get logging on and work backwards from when the issue occurs?



  • @MonkeyFiend:

    I assume when the map disappears you can still adminchange to it?
    Have you got any mods loading like blackknight or lazermod etc.?
    What’s in your serverdownloadlist?

    1. Nope, and that’s what’s truly baffling. Since it is gone from the getserversdkmaps, I cannot change to it even with servertravel or adminchangemap. There are plenty other (8 total) custom maps in the list btw.

    2. No.

    3. No idea. I did some research on my server but I couldn’t find that file. Where should it be and how should I use it? The documentation was kind of poor and unfortunately I can’t run an EXE file, like the one Workshop-something-tool.exe.

    I noticed this related bug, on 2 different servers, and that txt was nowhere, which is why I’ve been using the -sdkfileid parameter and a list of startup lines to download or update things.

    I don’t exactly know what causes this issue but 3/5 times bug has happened, we had switched to a custom map outside the rotation (which, remember, has only 2). When that map finishes, the next map will be the default one. It may or may not affect the following rotations, and since it’s been hard to narrow down what causes it.

    Any more ideas? :p Thanks for your itme



  • Alright, I finally got time to sort through the log files.

    I get a lot of weird errors warnings and errors like

    [4447.49] Warning: Warning, Invalid SDK Map name [b]AOCFFA-Duelyard_p,[/b] server will transition to [b]AOCFFA-Duelyard_p[/b]
    

    Also, warnings:

    [4426.35] Warning: Warning, UAOCDownloadableContentManager::StateGetFileDetails failed 298849843
    

    This happens every 4 or 5 rotation cycles. When the server gets this error, you get a “Server tried to transition to an invalid file”.

    However, it seems the server does register them as existing somehow…```
    [4447.80] DevDlc: SDK Level Mod: aocffa-duelyard_p
    [4447.80] DevDlc: SDK Level Mod: AOCFFA-Evergreen_p

    
    This, apparently causes the server to crash or restart automatically, because after a few of those weird loops between "invalid maps" (that were perfectly playable moments before) I've noticed this
    
    

    [4458.56] Log: StartOnlineGame() LAN Match: 0
    [4458.56] Log: StartInternetGame() 1

    That line usually happens when the server starts, isn't that right? Which is obvious when you consider this other line:
    

    Error: Can’t start an online game in state 3

    I'm attaching the full log.
    The TC Admin panel, btw, goes bananas and stops responding for a while.