Cannot connect to server



  • Hello,
    I am having issues hosting own Chivalry: Medieval Warfare “dedicated server”. Whenever I try to connect to it, and it IS visible in server browser, following window pop ups: “Information: Please wait while the game loads…”, and after 5-10 minutes it says that the connection has been lost or something. Keep in mind I can join other servers without a single problem.
    First I tried hosting the server on own computer (Windows7 64bit) and I, along with a friend through internet connection, could connect only when DMZ was enabled in router. Unlocking following ports did not help: 7777 7778 27015, and own port of 8277 for testing purposes. No firewall or anti-virus software was enabled at any time, so I’d guess as much they are not the problem.
    Now I attempt to host the game server on VPS OpenVZ which runs on ubuntu 12.04 and exactly same issue happens. Nothing shows up in the server logs. There is no protection software on the server. Doubt it’s the server’s itself fault, as it was previously used to host other things, which worked flawless.
    How do I fix that?



  • Hey SiRFI,

    This actually does sound like port 7777 is not being forwarded correctly.
    If it shows in the serverlist, this means that port 27015 is being forwarded corerctly.
    Are you sure, in ubuntu, that iptables is off?



  • Perhaps I am doing something wrong. Can You guide me towards disabling iptables?



  • Know that this is only a way to diagnose the problem; So do not keep it off.

    –But as I just checked, seems Ubuntu allows all traffic by default on install?

    This would be it on Ubuntu though;
    sudo service ufw stop