Unplayable Frame Rate.



  • After trying to find help in the Steam Community I was unable to find a solution to my problem so I’m posting here.

    I’ve reinstalled the game a couple of times, messed with some of the ‘fixes’ people have for low fps but nothing has worked. When I launch the game the splash screens run well and have good fps but as soon as I get to the menu I’m getting about 1fps. Changing the settings doesn’t help anything, nor does switching between fullscreen and windowed. This happens when I launch the game in Safe Mode as well. I have attached the DxDiag file but can’t locate a Launch.Log file.

    Any help would be great, thanks!

    Here is a link to the thread on Steam :http://steamcommunity.com/app/219640/discussions/0/613937942917808407/

    My PC specs are on my Steam profile page here: http://steamcommunity.com/id/jamdude



  • run the game in directx 9. it runs really crap in 11.





  • @LongSun:

    run the game in directx 9. it runs really crap in 11.

    @loin:

    http://forums.tornbanner.com/showthread.php/21826-FPS-locked-62?p=271665&viewfull=1#post271665

    The game always launches in DX9, here’s a screenshot: http://i.imgur.com/zYbv0pw.png. How do I launch it in DX11, maybe that will help?



  • You can put -dx11 as a launch option from steam to force dx11 mode, but I don’t know how well it works. Crashes mine.

    When you set the options from CCC did you make sure to set it on the 64-bit game exe?

    Quite a mystery. Maybe it’s a crossfirex problem or something… can you disable it?



  • I have tried both tbh and found a 10fps frame variance with -dx11 but 1 or 0 with -dx9.
    with a rig like the op’s it should be quite ok with no launch options and bsmooth at max 90 etc



  • @dudeface:

    You can put -dx11 as a launch option from steam to force dx11 mode, but I don’t know how well it works. Crashes mine.

    When you set the options from CCC did you make sure to set it on the 64-bit game exe?

    Quite a mystery. Maybe it’s a crossfirex problem or something… can you disable it?

    It seems to work well in DX11 in Deadliest Warrior, not in Medieval Warfare though.

    @loin:

    I have tried both tbh and found a 10fps frame variance with -dx11 but 1 or 0 with -dx9.
    with a rig like the op’s it should be quite ok with no launch options and bsmooth at max 90 etc

    Yep DX11 has done it for me, just need to re-read some of those articles about getting low frame rate in Medieval Warfare and use some of those fixes. Deadliest Warrior is working well now though.

    Thanks everyone for the help.



  • Is it only this game? It sounds like you are running on integrated. There is no way a 290X should be getting less than 60fps on this game.



  • @entire:

    Is it only this game? It sounds like you are running on integrated. There is no way a 290X should be getting less than 60fps on this game.

    It is only on this game and my iGPU is disabled.



  • I got major fps problems aswell since the patch



  • ^Same for me.



  • Hello everybody,
    Dear developers,

    You should reduce the mentionned parameters(see quotes) when playing on “Low” preset. And adjust to “Medium”, “High” …

    My config is 2 and half years old containing the following:

    • Nvidia Geforce GT 540M (yes, a laptop)
    • 8g ram
    • Intel Core i7-2670QM (2.20Ghz each cores)
    • Windows 7 64x

    Ok here we go.

    I bought the game during the previous discount. I wasn’t really interested in it, but i was bored, and figured i might as well spend some time on a new game.

    I launched the game, the “preset” was on “High” and figured that my machine still rocks. Oh god, was i wrong.
    I start my first game, and it was too slow, really. barely 5-15fps, unplayable.

    After hours, i finally found my way to the file UDKSystemSettings.ini and began tweaking my file. I began long hours of testing to increase my FPS.

    THEN, i reached the following block:

    UnbuiltWholeSceneDynamicShadowRadius
    UnbuiltNumWholeSceneDynamicShadowCascades
    WholeSceneShadowUnbuiltInteractionThreshold

    After i reduced the previous parameters, with these values:

    UnbuiltWholeSceneDynamicShadowRadius=4000.000000
    UnbuiltNumWholeSceneDynamicShadowCascades=1
    WholeSceneShadowUnbuiltInteractionThreshold=25

    **i earned +25~ FPS.
    **
    I can now PLAY your game just fine. And here i almost lost all hopes, i’m glad i didn’t give up.

    You should really SHOULD lower these 3 parameters for “Low” preset.

    Playing at ~45 FPS is far better than 15-20fps :biggrin-new:

    This is what “Low” should represent:
    https://dl.dropboxusercontent.com/u/5545718/Chilvary/chilvary_myconfig.TXT

    Otherwise, thanks for the game, i’m gonna slash some more now. :playful: