Smoothframerate



  • Hi all,

    I just want to share an experience about smoothframerate.

    Prologe:
    When I started to play Chiv I had an 60hz monitor and used V-Sync couz I hate tearing.
    The motion performance in multiplayer really sucked because people move stutterish and if they turn it looks like they turn in 45° “units”. If they turn fast it feels like their animations have 5 frames and its 90° “units”. What was even worse, they had like a “shadow” or “stroboscobe” effect. I looked like they were under electricity when moving. Sorry for that strage description.
    I checked the net for tipps about that and came to the topic that said “enable smoothframerate” in the UDKSettings.

    Main Story:
    Now i have a Benq 144hz and I have to say, the difference is really huge from the point of fluid gameplay. But still people turned so stutterish, and hits and swings always felt offsync even with good ping (~40) and this even with 144 fps with V-Sync.
    Yesterday I was so angry about that that I tried some things and I recognised that if you set smoothframerate to false you only get 90 frames, but people moved much more fluid. The “shadows” aren’t there anymore. I tried just for fun to diasble tripple buffering in the nvidia control panel. It makes no sense but it feels even better when disabled.

    Conclusion:
    -Dont set smoothframerate to true, 144 frames in multiplayer will suck because of the “shadow” effect
    -get a 144hz monitor (I know they are expensive)

    PS:
    In single player I have still 144 fps. So I guess there is another config for single player. Can someone confirm that?

    BR
    Andy



  • in unreal 3 engine clients have their FPS capped in multiplayer for some reason

    the laggy animations are most a result of bad netcode, the animations dont update fast enough usually

    if you watch slow motion footage of the game it should still look choppy lol