New listen servers not visible in serverlist



  • Not much to add to the title really.
    My friends are able to join off my ip, or through the friends tab ingame but the server doesn’t seem to be in the master list anywhere.

    Ports are forwarded as per patch notes.

    Others experiencing the same problem ?



  • This is usually the issue that the Query Port isn’t forwarded correctly.



  • Where abouts in the ini files should the query port be defined?
    From the patch update thread the defaults are 7777 and 27015, which I both have forwarded.

    If people can join then 7777 must be correctly forwarded (presumably), and 27015 is forwarded no differently.
    Unless for some reason in my ini files it’s not the default I’m not sure about that.

    Edit: UDKEngine.ini has default queryport 27015.



  • Can you reach the port 27015 via the outside? Use telnet or a portchecker.
    If anything, try port 27020 or such and see if that works. A lot of servers use 27015 by default these days.(Thanks Steam)



  • for me even feature with steam friends listen server doesn’t work…

    I tried with 2 diferent ppl, no succes

    we can create only listen server and with bots but when someone tries to join -> “server is not responding”

    is there sth special what needs to be done to play via my own listen server?
    (not from CMW browser) I mean from steam friends list - feature Devs declare should work now

    I create, I invite him -> and for my friend server is not responding (or vice versa)



  • I suspect a listen server would not work if they try to join you via friends.
    You get the internal IP of the server, which they cannot reach.
    They can only reach the external.



  • Listen servers added**

    • Players can now host their own servers and play with their friends. Start a listen server from the Create Game screen.
    • The Steam master server will not NAT punch; i.e., unless you forward ports on your router (default: 7777 and 27015) you will not see your server in the server browser. However, it will show as a LAN server on your LAN, and will also be joinable through the Steam friends list (not the Friends tab in the browser)

    **

    Thanx Raizio for quick respond,

    so have I misunderstood it?

    I thought this means I have to make some settings only if I want other ppl (who are not in my steam friends list) in game to be able to join my PC when they search game server

    so you say only LAN works?

    maybe someone could correct patch notes then or give some more info
    (am not very experienced with “servering”, though I can set up my wifi router :D)



  • In my general networking experience; Especially if it says it will not nat punch…you’ll still need to forward ports.
    7777 alone should do it for steam friendslist.



  • @Raizio:

    In my general networking experience; Especially if it says it will not nat punch…you’ll still need to forward ports.
    7777 alone should do it for steam friendslist.

    @viral:

    Not much to add to the title really.
    My friends are able to join off my ip, or through the friends tab ingame but the server doesn’t seem to be in the master list anywhere.

    Ports are forwarded as per patch notes.

    Others experiencing the same problem ?

    ahhh thank you guys, I see I misunderstood this feature
    (sorry I am not native EN speaker and word “However” confused me to another meaning of sentence)

    so what patch notes endavour to say is:

    forward ports to enable listen servers via
    a) LAN and
    b) steam friends invite

    • no, you can’t join to listen server in normal server browser in game
      (this is good thing, so no you don’t have to worry that strangers will ocuppy yr PC)

    thanks for explanation Raizio I will forward those ports then :)



    • no, you can’t join to listen server in normal server browser in game
      (this is good thing, so no you don’t have to worry that strangers will ocuppy yr PC)
    1. You should be able to.
    2. That’s not really how the internet works.

    @ Raizio I’ll try changing the query port.

    Edit: ayy it worked sick cheers bro


Log in to reply
 

Looks like your connection to Torn Banner Forums was lost, please wait while we try to reconnect.