Servers in server list not appearing after clicking 'Join'



    • SOLVED

    Reinstalling Steam made the game fully functional!

    • The issue.

    When I click on the ‘Join’ button in the main menu, I can’t see any servers in the server browers (Including History, Favorites, Friends and LAN).
    I can see the Chivalry servers in the Steam server browser, but when I join one Chivalry says: “Your connection to the host has been lost.”. This also happens when I try to connect to a server using the console and the command “open [IP]:[port]”.
    Another weird thing is that when I try to create a game, the game stops responding in the load window, but when I create a game using ‘Start offline game’ it does work (the offline training also works).
    Customizing characters does work, however, clicking the workshop/community buttons crashes the game.
    I am aware of the “Server Browser Issues” thread by DaGGyzo, but decided to make this anyway to share all my information.

    • Solutions I tried.

    ​From the Giant Solution List:**

    **Solution 2: Deleting your C:\Program Files (x86)\Steam\config\MasterServer2.vdf to force Steam to regenerate it may help.
    The file doesn’t exist in any of my steam installation folders.

    **Solution 3: Make sure you are running the main game and not the beta. You’d be surprised how many people make this error.
    Done. Didn’t work.

    **Solution 4: Go into Steam. Click on Steam > Settings> Beta participation > Change > Steam Beta Update. Set this to join for the beta. Restart Steam. Run Chivalry Medieval Warfare and go into the Server Browser. Restart the game and try again.
    Done. Didn’t work.

    **Solution 5: Try Remixx’s wonderful alternate server browser here.
    Doesn’t work anymore.

    Solution 6: Your router may not be able to handle the sheer quantity of connections that Steamworks is creating to query servers. In Steam, click Steam -> Settings -> Downloads+Cloud. Change the “Game server browser: max pings / minute” setting to something lower.
    The option doens’t exist.

    **Solution 8: View Steam’s guide for Troubleshooting Network problems. Look here.
    Done. Didn’t work.

    **Solution 9: Restart Steam. I know I’ve mentioned this already but it could be Steam causing problems so it’s always a safe bet to restart it just to make sure.
    Done. Didn’t work.

    **Solution 10: Create a game with bots, play for a bit then try joining a different server.
    Done. Didn’t work. (As explained before.)

    **Solution 11: Try rerunning the redist in C:\Program Files (x86)\Steam\steamapps\common\chivalrymedievalwarfa re\Binaries\Redist\UE3Redist.exe
    Done. Didn’t work.

    **Solution 12: You may have a software firewall, hardware firewall, security software, or some other software or hardware interfering with Steamworks’ ability to list servers. Please try without any firewalls if possible, and if you have your own router try bypassing it and connecting to your ISP’s internet connection directly.
    I disabled my firewall and quit all programs apart from Steam. Didn’t work.

    **Solution 13: Click Start button and cut and paste this into your run dialog box, “C:\Users%USERNAME%\Documents\my games\Chivalry Medieval Warfare\UDKGame” and hit enter
    ** If the above doesn’t work, try this: “%USERPROFILE%\Documents\my games\Chivalry Medieval Warfare\UDKGame” ** You will see a “Config” folder. Rename it to “Config.old” Start Chivalry and see if the server list is working now.
    Done. Didn’t work.
    **
    Solution 15: On Windows firewall, look for “Allow an app or feature through windows firewall”. Find Chilvary on the list and make sure both private and public check boxes are active. You can also disable windows firewall just to make sure but remember to have it enabled later.
    Done. Didn’t work.

    **Solution 17: You may have to open your ports for Steam to properly allow you to connect. You can find the list of portshere.
    ******Opened all the required ports for my computer’s local IP. Didn’t work.

    ****************************************I tried restarting Steam/Chivalry many times, didn’t work. Also restarted my computer multiple times and waited a night, didn’t work.
    I tried setting the perspective filter to First Person, saving and back to all, didn’t work. All my other filters are at default settings.

    • Extra information.

    This is a link to an album I made with screenshots of the problem: http://imgur.com/a/tdSmk
    DxDiag.txt and Launch.Log (renamed file extension) are in the attachments.
    I hope this information could resolve the problem, if you want to know anything more or have any other solutions I should try please tell me.
    I thank you in advance.

    • Mutorials

    P.S. Sorry if I did anything wrong, this is my first post and English is not my native language, so there can be some spelling errors.