Game work on integrated GPU instead of dedicated GTX



  • I’m using laptop so i have 2 GPU’s, GTX 660M which is dedicated and integrated intel 4000HD. Game which i start via steam is running on integrated one and is not playable. Can someone help me?



  • Please provide make and model so that I can look it up. But you may have to go into the bios and make sure you have the right GPU/PCIE card selected as the one to boot with. You may also have to disable the intel card in the device manager in the OS so that it doesnt load the drivers. Also check the Nvidia Settings for GPU/CPU physX and test which one works better for you. Another thing you can do that will help is increasing the priority of Chivalry. You can find info on this on my forums, along with other tweaks you can try: http://kilas.enjin.com/home/m/383971/viewthread/8150123-set-priorty-to-high-for-chivalry



  • It might also be worth considering making another hardware profile in settings and allowing a 20 second countdown
    at bootup. In one profile disable the video setting you don’t want to use and name it say dedicated in the menu.
    I have this on a pc with it called Nvidia and profile 1. ( profile 1 being used for my ati card instead ).



  • @Ruszofy:

    I’m using laptop so i have 2 GPU’s, GTX 660M which is dedicated and integrated intel 4000HD. Game which i start via steam is running on integrated one and is not playable. Can someone help me?

    Hello,

    I have the same kind of Laptop (but a lesser graphic card ;P)

    • Open Nvidia control panel
    • 3d parameters -> manage 3d parameters
    • global parameters -> prefered graphic processor
    • Choose Nvidia High Performance

    Or,
    you can try to set manually for the game to use the Nvidia one (Tab “program parameter”)


Log in to reply