Unable to Join Certain Servers



  • So, i have found a number of other users who have experienced this same issue in the Steam community and from this forum, but I haven’t found any real “fix action” for the problem?

    Here’s my issue:

    Server list populates just fine, but when I attempt to join a server, about 90% of the time the game hangs at “Please wait while the game loads”

    Eventually, you will get another message that says “Connection to host has been lost”

    What’s frustrating is that there are some servers that I can join with no problem, they will load up right away, but there are a handful of servers where I have a low ping (~50-60) that I can just never get in.

    Tried a bunch of the things in Kimiko’s “Giant Solution” list, doesn’t seem to work.

    One thing I have noticed is that when verify the game cache or whatever, it says “4 files will be re-acquired” but nothing seems to download after that?

    Very frustrating. Love the game, so I guess I will just continue to play in “Chivalry Korea” cause that’s like, the only server I can play in.

    Any reply would be appreciated, thanks!



  • Hey GemCity, I’m having the exact same issue, and I haven’t found anyone else with the problem. It’s frustrating.

    My specs:

    Q6600 Quad 2 Core @ 2.4GHz
    4 GB 800MHz RAM
    GTX 560 Ti
    Windows 7 - 64 bits.

    Launch.log:
    http://pastebin.com/raw.php?i=Ts2WfqyJ

    Would love to hear back from you Torn Banner, haven’t been able to play in a while :(



  • It is relatively new, it happened after the last patch which fixed the server browser crash. It is completely random, not server specific (I generally stick to 3 or 4 servers), sometimes you get in immediately, other times you hang for fucking ever. It is a source of frustration, made worse that when you hit cancel because you know its not going to work that time - you go back to the main menu and have to start all over again.

    Waiting for people who do not play the game to provide their input…



  • Have you tried using the console command and seeing if that changes anything? Find the IP+port using server browser then open console and type “open IP:PORT”.



  • are u still faced with this issue ? If no , please share on how you managed to fixed it as I am also faced with this annoying issue


Log in to reply